Networking works for exactly five minutes after a reboot, then stops

Keywords: ResourceSpace - Virtual Machines - Technical issue - Other
Description:
This is happening with multiple Bitnami VMs that I’ve tried to run. ResourceSpace is just one example. The problem has happened with every Debian-based VM I have tried so far. On booting the system networking works initially, then suddenly stops working. It always stops EXACTLY five minutes after bootup. My best guess is that this is somehow related to DHCP and predictable interface names or something like that. Not the slightest clue where to even begin looking. Have done multiple google searches, found numerous threads, nothing helpful so far.

I’m confused by this, because it seems pretty weird that something could be so fundamentally broken and nobody notice, but I can’t find any references to this behavior.

Hi @hostmaster,

Sorry for the inconvenience. Could you please let us know more information about the environment you have?

  • How did you detect the issue? Can’t you access the application using the web browser or did a command fail when running it in the console?
  • What’s the host OS?
  • Are you using VirtualBox to deploy the VM? What’s the network configuration? We always suggest to use a “Bridged Adapter” as network adapter, what’s the network configuration of the VM?
  • Our VMs have some hardcoded nameservers (8.8.8.8 and 8.8.4.4), can you check if adding other nameservers fix the network issue?
  • Does the VM have valid network configuration when the issue appears? Please run this command when the network doesn’t work
sudo ifconfig

Thanks

I’m using VirtualBox (the latest version) on a Windows 7 workstation. The VM is configured with 4GB of RAM and 2 cores, and VT-x is enabled. The network adapter is configured as a bridged adapter.

I first noticed the problem because I was using the ResourceSpace site and it suddenly timed out. After restarting, it worked for a while, then again suddenly stopped. I began troubleshooting and found that it was losing network connectivity after a few minutes.
It’s not a DNS issue, the network is completely unusable after five minutes, can’t ping the machine, can’t ping other resources from within the machine.

ifconfig is not installed with this package, but ip addr returns the results shown below.

Immediately after boot, the machine has network access. Interface enp0s3 has an IPv4 addess, and I can access the machine over the network.


Exactly five minutes after booting up, the network stops responding, and running ip addr shows that there is no longer an IPv4 address for the interface.

If I look in /var/log/error I see the following messages…
dhclient[1638] Failed to get interface index: No such device.
and
systemd[1]: Failed to start Raise network interfaces.

It seems like some things on the machine are trying to use eth0, but that interface doesn’t exist. Not sure if that is related.

Hi @hostmaster,

If you’re using the Bitnami ResourceSpace OVA or VMDK, ifconfig should already be installed. Note we refer to ifconfig and not ipconfig (which is Windows-specific).

Have you tried manually creating a DHCP lease? Do you see any error?

sudo dhclient -v

In addition to that, if it still fails, you could try to configure the network manually by adding the following text to the /etc/network/interfaces file:

auto enp0s3 
iface enp0s3 inet static
    address 10.5.100.125
    netmask 255.255.255.0
    gateway 10.5.100.1
dns-nameservers 8.8.8.8

After that, you would need to reload the configuration and restart the interfaces:

sudo ip link set dev enp0s3 down
sudo ip addr flush dev enp0s3
sudo service networking stop
sudo service networking start
sudo ip link set dev enp0s3 up

I hope it helps!

Hmm, I’m running bitnami-resourcespace-8.5.11461-0-linux-debian-9-x86_64.ova right out of the box, and running ifconfig gives me:
-bash: ifconfig: command not found

I have the same situation with bitnami-pimcore-5.3.1-0-linux-debian-9-x86_64.ova as well.
Same disconnect symptoms, and ifconfig not found.

I will try the recommendations and see what happens.

Some additional information:

bitnami@debian:/$ sudo /etc/init.d/networking stop;
[ ok ] Stopping networking (via systemctl): networking.service.
bitnami@debian:/$ sudo /etc/init.d/networking start;
[…] Starting networking (via systemctl): networking.serviceJob for networking.service failed because the control process exited with error code.
See “systemctl status networking.service” and “journalctl -xe” for details.
failed!
bitnami@debian:/$ systemctl status networking.service
Failed to connect to bus: No such file or directory

There was nothing visible in the journalctl output at the time of the disconnect.

Hi @hostmaster,

Regarding ifconfig, it is usually only available for privileged users/sudo:

sudo ifconfig

Also, if you see errors with the networking service, you can run the command below to get more info:

sudo service networking status

Remember to run the “systemctl” command with privileges/sudo.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.