Need to change password so PEM key does not work

Keywords: CouchDB - AWS - Technical issue - Credentials
Description:
I paid somebody to solve a problem and gave them my PEM/PPK key for access to https://aws.bitnami.com/vms/bitnami-couchdb-cf-fcb0. I changed my AWS password but this is for the bitnami root access I believe. User: admin
Are these the right instructions?
https://console.aws.amazon.com/iam/home#/home

Hi @jhchadwick63,

Thank you for using our solution and contacting us but it’s not clear to me what you are trying to achieve. In this thread you posted a screenshot of the deployment you launched in the Bitnami Launchpad (I just removed that post because it contains the IP and the credentials of your deployment) and mentioned that someone changed the password of CouchDB. What do you mean with this next sentence?

Do you want that other person to not to have access to the instances you launched? Does he have the credentials to access your Bitnami account or does he only have the PEM key?

Thanks

Thanks for that, I didn’t realize my password was showing. Sorry for not being clear. See, I had given a guy my PEM key so he could login to the bitnami server and resolve some issues. I am a little unclear about passwords and access. I want to make sure his PEM key no longer works since he is done the work. The PEM key was downloaded from that page shown in the screen shot. I am still using he same PEM key as well to login. My host name is:
bitnami@ec2-18-214-95-156.compute-1.amazonaws.com
user name: bitnami
Then I understand the password info is in the PEM key.

I changed the password I use to sign into the AWS console but still the PEM key works. So where do I change the password so I must download a new PEM key from that page?

Thanks.

Hi @jhchadwick63,

I’m sorry but the Bitnami Launchpad doesn’t support reset the SSH key. That SSH key is generated when you first access the Launchpad and configured your account and all the deployments you launch use the same key.

What you can do is to generate a new SSH key in your computer and configure the bitnami user to use that new key and remove the default one. That way, the other user won’t be able to access the instance anymore.

https://docs.bitnami.com/aws/faq/administration/provide-additional-ssh-access/

This section has information about how to configure the instance that way (you will need to follow the option B in the step 2).

Another option would be configure SSH to access the instance using the SSH key plus a password. Will that work for you?

Thanks

That last option worked. I just tested (keep the one session going and test in another session so you don’t lock yourself out)
AuthenticationMethods “publickey,password” “publickey,keyboard-interactive”
Details here:
https://serverfault.com/questions/93807/how-do-i-setup-sshd-to-require-both-a-private-key-and-a-password

Thanks jota, you came through again.

Perfect @jhchadwick63 :slight_smile:

Can we mark this thread as solved?

Yes, good enough for me, thanks.