Need Help ! HTTP: failed to make connection to backend

Keywords: OpenEdX - Virtual Machines - Technical issue - Services (Apache, MariaDB, MySQL…)

bndiagnostic ID: 20979d07-7977-4aa2-1955-8770acc5c732

bndiagnostic output:

? Apache: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
I got errors when using bndiagnostic-tool:

[Tue Apr 26 03:00:24.710919 2022] [proxy_http:error] [pid 1321:tid 140533678601984] [client ip_address:3149] AH01114: HTTP: failed to make connection to backend: 127.0.0.1
[Tue Apr 26 03:00:24.747399 2022] [proxy:error] [pid 1321:tid 140533619853056] (111) Connection refused: AH00957: http: attempt to connect to ip_address:8000 (127.0.0.1) failed Press [Enter] to continue:
[Tue Apr 26 03:00:24.747432 2022] [proxy_http:error] [pid 1321:tid 140533619853056] [client ip_address:3150] AH01114: HTTP: failed to make connection to backend: 127.0.0.1, referer: http://192.168.11.125/

Someone can help me, please!!!

Hi @tntan,

Did you change any configuration files or install any plugins or themes?

Regards,
Michiel

Hi @michiel

I don’t change any configuration files and don’t install any plugins or themes.

Can you help me to fix this issue.

H @tntan,

Could you try restarting the services?

sudo /opt/bitnami/ctlscript.sh restart

Regards,
Michiel

Hi @michiel
Thanks for your reply.

When we try restarting the services

sudo /opt/bitnami/ctlscript.sh restart

we got these error message: Job for bitnami.service failed because the control process exited with error code.
See “systemctl status bitnami.service” and “journalctl -xe” for details

And when we run: systemctl status bitnami.service, we got error message: Failed to connect to bus: No such file or directory

Hi @tntan,

Could you launch a new instance and check if the same error happens again?

Regards,
Michiel

Hi @michiel,

We launched the new instance and the same error still occurs.

Our tests succeeded when releasing the solution so it should be working properly. Could you please let us know more details about this new launch?

  • Are you using the local VM or a cloud instance? If a cloud instance, in what cloud platform?
  • What are the settings you selected when launching the instance? (region, RAM, CPU, …)

Hi @jota

I’m using Local VM with 8GB RAM, 2 CPU, 50GB HDD and Region US

Are you using VirtualBox? Does the host machine have enough RAM memory to run that VM?

Hi @jota ,

I’m using VirtualBox with 8GB RAM and host machine have 16GB RAM.

Hi @tntan ,

As I mentioned, our tests succeeded and I couldn’t reproduce the issue locally, all services were up and running without problems and the app was working properly. Please remove that VM, download the latest version from the bitnami.com site and redeploy the solution using that new OVA.

Thanks

Hi @jota

After download and deploy with new OVA from bitnami.com, i’ve got these error:

$ sudo /opt/bitnami/ctlscripts.sh start
Job for bitnami.service failed because the control process exited with error code.

$ sudo /opt/bitnami/ctlscripts.sh status
Control file ‘/etc/gonit/gonitrc’ does not exists

Hi @tntan ,

Please note that it takes some time for the VM to be fully deployed. Did you try to run the commands after waiting for 5 or 10 minutes?

A post was merged into an existing topic: Bitnami HTTPS Configuration Tool (bncert) corrupted my installation

Hi @jota,

I’m run the commands after waiting 30 minutes.

I think there is a problem during the initialization of the VM in your computer. Is there any error in the /opt/bitnami/var/log folder?

sudo cat /opt/bitnami/var/log/*