MySQL password for Bitnami on Lightsail

Hi,

Where is this password stored as the bitnami_application_password is not working?

It is needed as I am trying to install Bitnami Wordpress on top of the Lightsail LAMP:

Thanks

Hi @aconti,

The bitnami_application_password file is located in your home directory. You can read it with the following command:

sudo cat /home/bitnami/bitnami_application_password

It is described in this guide: https://docs.bitnami.com/aws/get-started-lightsail/#step-2-deploy-wordpress-on-amazon-lightsail

I hope it helps!

1 Like

I am using LAMP and am encountering the issue while installing WordPress as need to know the sql password to proceed (the one in bitnami_application_password does not work)

Warning: The installer was not able to connect to the MySQL server. Please make
sure MySQL is running and introduce a valid password to connect to the MySQL
server.
Press [Enter] to continue:----------------------------------------------------------------------------
Create Admin account

Please enter the existing MySQL password for Bitnami

Hi @aconti,

If you’re unable to find your MySQL root password, could you follow this guide to reset the MySQL root password? https://docs.bitnami.com/?page=components&name=mysql&section=how-to-reset-the-mysql-root-password

I hope it helps!

the setup seems to refer to the password for the Bitnami user (and not the root user), see attached:

I can also login fine to mysql with both root and the newly create bitnami user account (using command mysql -u root (or) bitnami -p)

Hi @aconti,

The installer is asking you for the password for the MySQL “root” user. The wording is a bit confusing and we’ll look into it.

If the password shown in the bitnami_application_password file is not valid (which is already strange), you can reset the MySQL root password as I mentioned above: https://docs.bitnami.com/?page=components&name=mysql&section=how-to-reset-the-mysql-root-password

Not that you should also make sure MySQL is running as you may be able to log into the CLI without it being running:

sudo /opt/bitnami/ctlscript.sh start mysql

I hope it helps!

ok will run that script and let you know…

Get Outlook for Androidhttps://aka.ms/ghei36

no luck am afraid

Hi @aconti,

There are a few issues with your configuration.

First of all, you need to run the installer with “sudo”, as the stack was installed as root:

sudo ./bitnami-wordpress-4.8-0-module-linux-x64-installer.run

Next, it seems you’re specifying a wrong installation directory, becase when the installer asks you for this:

Select a folder []:

You should specify “/opt/bitnami”.

I hope it works now!

nice one it worked:

Please wait while Setup installs Bitnami WordPress Module on your computer.

Installing
0% ______________ 50% ______________ 100%
#########################################


Setup has finished installing Bitnami WordPress Module on your computer.

Hi! Nice to know it’s working :slight_smile: Please let us know if you run into more issues.

Best regards,

Javier J. Salmerón


Was my answer helpful? Click on :heart:

@jsalmeron, @Marcos: I’m running into the same problem.

$ sudo ./bitnami-mediawiki-1.33.0-1-module-linux-x64-installer.run
----------------------------------------------------------------------------
Installation folder

Please choose a folder that contains an installation of Bitnami.

Select a folder []: /opt/bitnami/

Note: You should select the previous installation of Bitnami. For example: 
/opt/bitnami



----------------------------------------------------------------------------
Create Admin account

Login [user]: admin
Please enter the MySQL password for "root" for the existing Bitnami installation

Password :

Enter the application password :
Retype password :
Warning: The installer was not able to connect to the MySQL server. Please make 
sure MySQL is running and introduce a valid password to connect to the MySQL 
server.
Press [Enter] to continue:1§§1^[§^C
bitnami@ip-172-26-13-156:/opt/bitnami$ 

The password I’m using is the one in the bitnami_credentials file.

$ sudo /opt/bitnami/ctlscript.sh start mysql
/opt/bitnami/mysql/scripts/ctl.sh : mysql (pid 1916) already running
Monitored mysql

Hi @gk2go,

Are you able to connect to your MySQL root user manually? E.g.:

mysql -u root -p

And enter the password in the bitnami_credentials file.

If it does not work it is possible you had changed the root password previously. If so, you can reset the MySQL root password. After this you should be able to log in to MySQL.

@Marcos, I can login to mysql with the same password:

~$ mysql -u root -p
Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 8
Server version: 5.7.25 MySQL Community Server (GPL)

Copyright (c) 2000, 2019, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

No entry for terminal type "linux";
using dumb terminal settings.
Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql>

Hi @gk2go,

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please download and execute it on the machine where the stack is running by following the steps described in the guide below?

How to Run the Bitnami Support Tool

Please note that you need to paste the code outputted by the tool in your reply.

@michiel, here is the code: bfc33c14-f4b2-04e5-279d-fb890aadd08d

I had btw solved my issue on another machine installing Mediawiki with git, but I kept this instance just to get to the bottom of this issue, for future reference.

Thanks

Hi @gk2go,

Thank you for the information. Can you try to install the Bitnami Mediawiki solution again and share the content of the installer’s log if it fails? You can find the installer’s file in the /tmp folder of the machine

sudo ls -la /tmp/bitrock_installer*log

Thanks

@jota, it now works!
What changed since I sent you the code?

We are glad to hear that everything is working properly now :slight_smile:

We have not changed anything @gk2go. Don’t know if you didn’t write the database’s password correctly before or if the database was not running for some reason.