MySQL not starting on AWS Lightsail

Keywords: MySQL - AWS - Technical issue - Other
bnsupport ID: 787e5abd-64d5-59ce-2873-41b44f373dd3
Description:
I am unable to get MySQL to start. Have tried restarting via the control script /opt/bitnami/ctlscript.sh provided, but it still doesn’t restart . PHP and Apache are fine and able to restart

Below is my error log file using the tail command

Error log is below
bitnami@ip-172-26-13-240:~$ sudo tail /opt/bitnami/mysql/data/mysqld.log
2021-04-05T03:51:40.946143Z 0 [System] [MY-010910] [Server] /opt/bitnami/mysql/bin/mysqld.bin: Shutdown complete (mysqld 8.0.23) MySQL Community Server - GPL.
2021-04-05T03:52:32.683960Z 0 [System] [MY-010116] [Server] /opt/bitnami/mysql/bin/mysqld.bin (mysqld 8.0.23) starting as process 2511
2021-04-05T03:52:32.722174Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2021-04-05T03:52:33.385606Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2021-04-05T03:52:33.696639Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: ‘::’ port: 33060, socket: /tmp/mysqlx.sock
mysqld.bin: File ‘./binlog.000010’ not found (OS errno 2 - No such file or directory)
2021-04-05T03:52:33.740283Z 0 [ERROR] [MY-010958] [Server] Could not open log file.
2021-04-05T03:52:33.740433Z 0 [ERROR] [MY-010041] [Server] Can’t init tc log
2021-04-05T03:52:33.740691Z 0 [ERROR] [MY-010119] [Server] Aborting
2021-04-05T03:52:35.157799Z 0 [System] [MY-010910] [Server] /opt/bitnami/mysql/bin/mysqld.bin: Shutdown complete (mysqld 8.0.23) MySQL Community Server - GPL.

Please HELP

I have tried rebooting my instance as well

Hi @rochak10,

Can you run the bndiagnostic tool? It looks for common errors and outputs possible solutions.

sudo /opt/bitnami/bndiagnostic-tool

Regards,
Michiel