My website stops and to start it I have to restart it

Keywords: General - Google Cloud Platform - Technical issue - Secure Connections (SSL/HTTPS)
Description:
Good day

to ask them for help.

I have the problem that my website stops, I don’t know the reason.
There are only 5 registered users, the web is new.

For it to work I have to go to google cloud and stop my VM, then I start it. It’s the way I make it work.

What I can do?

Hi @EngelDragoner,

We would need you to provide more information about your issue. Which machine size are you using? Which application and version? Did you modify the website somehow (plugins, themes…)? We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

hello, I get this after entering that tool.

The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
1212bc25-248a-80ca-b4a6-17b2678c1b03
And paste it in your Bitnami Support ticket.

values ​​in PHP.INI
memory_limit = 1024M
post_max_size = 1024M
upload_max_filesize = 1024M
max_execution_time = 300
max_input_time = 300

My theme is: Bizberg ShopVersión: 1.4

the plugins I have are:

AJAX Login and Registration modal popup DEV + inline form Versión 2.19
All-in-One WP Migration 6.77
Conditional Discount Rules For WooCommerce Checkout Versión 2.0.7
Contact Form 7 Versión 5.4.1
Cyclone Demo Importer Versión 2.9.3 |
Elementor Versión 3.2.4
Elementor - Header, Footer & Blocks Versión 1.5.9
Essential Addons for Elementor Versión 4.7.0 |
Join.chat Versión 4.1.14
One Click Demo Import Versión 3.0.2
Shortcode Elementor Versión 1.0.1
WooCommerce Versión 5.3.0
Wordfence Security Versión 7.5.4
WP Super CacheVersión 1.7.3
WPFront User Role Editor Versión 2.14.4
YITH WooCommerce Compare Versión 2.5.2
YITH WooCommerce Quick View Versión 1.6.2
YITH WooCommerce Wishlist Versión 3.0.22
Zoho Mail Versión 1.4.4

hello, I get this after entering that tool.

The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
1212bc25-248a-80ca-b4a6-17b2678c1b03
And paste it in your Bitnami Support ticket.

Hi @EngelDragoner,

The bnsupport tool found issues in the MariaDB logs related to the WordPress database, can you check it? It should have been returned from the tool execution, was it?

[Mariadb]

Found recent error messages in the MariaDB error log:

2021-06-21 16:23:44 16 [ERROR] mysqld: Table './bitnami_wordpress/wp_comments' is marked as crashed and should be repaired

Please check the following guide to troubleshoot MariaDB issues:

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mariadb/

Apart from that, I see other errors in the Apache logs that can be related to the plugins you installed. We recommend you to check them with the plugins developers

[Sun Jun 20 00:39:43.356158 2021] [proxy_fcgi:error] [pid 1320:tid 140583725029120] [client IP_ADDRESS:1734] AH01071: Got error 'PHP message: Payment gateway with handle 'wc-payment-method-bacs' has been deactivated because its dependency 'wc-blocks-registry' is not registered. Read the docs about registering assets for payment methods: https://github.com/woocommerce/woocommerce-gutenberg-products-block/blob/trunk/docs/extensibility/payment-method-integration.md#registering-assetsPHP message: Payment gateway with handle 'wc-payment-method-bacs' has been deactivated because its dependency 'wc-settings' is not registered. Read the docs about registering assets for payment methods: https://github.com/woocommerce/woocommerce-gutenberg-products-block/blob/trunk/docs/extensibility/payment-method-integration.md#registering-assets', referer: https://co_REPLACED_b.mx/

[Sun Jun 20 21:29:54.814773 2021] [proxy_fcgi:error] [pid 717:tid 140482919089920] (70007)The timeout specified has expired: [client IP_ADDRESS:22267] AH01075: Error dispatching request to : (polling), referer: https://cocosvb.mx/wp-admin/post-new.php?post_type=product                                                                                                                                                                                                                                            [Sun Jun 20 21:38:42.194104 2021] [proxy_fcgi:error] [pid 719:tid 140482910697216] [client IP_ADDRESS:30131] AH01067: Failed to read FastCGI header, referer: https://cocosvb.mx/wp-admin/post-new.php?post_type=product

I used this tool again:
sudo / opt / bitnami / bnsupport-tool

, I get this:

The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
f42f8b12-640d-520f-822b-dc4a22392e53
And paste it in your Bitnami Support ticket.

It also marks error in the ram, low memory

It also marks error in the ram, low memory.

How can I see what each plugin consumes?

when 2 or 3 administrators use the web, the web crashes.


With these tools I got this information but I don’t know what to do with it, I only know that it is filling up

https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mariadb/

$ test ! -f “/opt/bitnami/common/bin/openssl” && echo “Approach A: Using system packages.” || echo “Approach B: Self-contained
installation.”
Approach A: Using system packages.

$ test -d /opt/bitnami/mariadb && echo “MariaDB” || echo “MySQL”
MariaDB

$ test ! -f “/opt/bitnami/common/bin/openssl” && echo “Approach A.
Using system packages.” || echo “Approach B. Self-contained installation.”
Approach A. Using system packages.

Hi @EngelDragoner,

Checking the amount of memory each plugin consumes is not possible as far as I know, but according to your last bnsupport bundle, MySQL is consuming a lot of memory, which usually means WordPress plugins are doing an intense use of the database (mainly for caching information).

You will need to check which plugins are using the database. To do so, we recommend using the mysqldbinlog tool to check the database events

https://dev.mysql.com/doc/refman/8.0/en/mysqlbinlog.html

Additionally, we have a troubleshooting guide that will be of help to check the server performance

https://docs.bitnami.com/google/faq/troubleshooting/troubleshoot-server-performance/

Regarding the commands you ran, the output you got means your server is using MariaDB database and Approach A, therefore you can check the MySQL logs in the /opt/bitnami/mariadb/logs/mysqld.log file.

The same thing happens to me, I don’t even know what it is.
check the plugins and clean the database and remain the same.

I thought it would be due to the attacks of the bots that saturated my network, I already put the wordfence plugin and changed the url of wp_login,
still low ram memory

I measured the speed of each plugin and they are in the normal ranges.

It keeps happening to me that if there are several administrators that is when my problem arises, but if there are visitors to my website there are no problems.

I measure the ram in ssh with:
free -m

I know that there are problems with the database and the ram, I just don’t know how to identify the problem, from the individual tests I have done it says that everything is fine, but altogether there is something wrong

free -m

image

Hi @EngelDragoner,

Thanks for the screenshot. The memory is not in bad state according to the screenshot. A bit low, but should be enough to attend some users.

It keeps happening to me that if there are several administrators that is when my problem arises, but if there are visitors to my website there are no problems.

Did you have any chance to check the database events? Apart from that, I think this error is specific to the WordPress application. Can you open a new question in the official WordPress forums?

https://wordpress.org/support/forums/

Hi @EngelDragoner,

Can you also run the bnsupport tool again and share the new code with us?

thank you for your patience.

this is the new code that appears, this time all plugins are disabled

The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:

af8ec609-a2e9-2bfa-c7c0-34e7b126d38d

And paste it in your Bitnami Support ticket.


I think my next step will be

“start from scratch”, that is, what will I do with a new vm, will I import the databases and the images, or what do you recommend?

in the new VM, with the same plugins and same database.
just migrate the database and the images, the plugins install them from scratch.

this comes out:
The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
40838489-5410-067e-2bdb-db99baf9c5f0
And paste it in your Bitnami Support ticket.

I get low RAM and errors in apache, maybe it is because of the low ram.

How can I upload it more?
in the ini.php
the memory_limited is 1024

Hi @EngelDragoner,

Thanks for the new code. Unfortunately, this instance is also running out of free memory available. Did you have any chance to check the database events to find which plugin (or if it is the theme you are using) is using the database in an intense manner?

-----------------------------------
Display amount of free and used memory in the system
-----------------------------------
Running: free -m
In: /opt/bitnami

Output:

              total        used        free      shared  buff/cache   available
Mem:           1693        1334          97          78         262         140
Swap:             0           0           0

I also see almost all the requests to your website are comming from a single IP address. Can you check if it is a bot?

-----------------------------------
Check performance issues: Count number of requests for the 10 most active IP addresses in the last 100.000 requests
-----------------------------------
Running: tail -n 100000 access_log | awk '{print $1}' | sort | uniq -c | sort -nr | head -n 10 | awk '{print $1}'
In: /opt/bitnami/apache2/logs/

Output:

4006
1561
1082
1013
560
471
434
427
416
351

https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

I am checking this and I see that many errors to access tables, they say that it is locked and must be repaired, I attach an image. how can I do it?

me sale este error al aplicar este codigo en ssh:

sudo /opt/bitnami/bnsupport-tool

|
Error: There has been an error.
Unknown error while running /tmp/namiList.sh
Press [Enter] to continue:

it’s not me. I am the only one who had accessed and taken a lot of resources, with the WORDFENCE plugin, I configured it to block bots.

from my previous question, to reset the tables, is it connecting to my PHPADMIN or can it be done from ssh?

Hi @EngelDragoner,

According to the StackOverflow thread below, you can use the mysqlcheck tool with SSH to run the database repair

https://stackoverflow.com/questions/4357270/table-is-marked-as-crashed-and-should-be-repaired

However, we highly encourage you to create a server backup before doing any changes on your server to be able to restore in case it fails

https://docs.bitnami.com/google/faq/administration/backup-restore-server/

Did you also have any chance of using the mysqldbinlog tool to try to figure out which plugin is using the database a lot?

Can you also check WordFence is properly blocking the bots? If not, you can follow our guide to block them in Apache

I already repaired the tables that marked me, I see no difference in the ram memory.

I don’t know how to use the mysqlbinlog tool. I’m using it like this, but it comes out this:

mysqlbinlog --plugin-dir = / bitnami / wordpress / wp-content / plugins / ajax-login-and-registration-modal-popup
mysqlbinlog: unknown variable ‘default_character_set = UTF8’

how to write: mysqlbinlog ??

this is my new code:

The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
3c424f5a-1a2d-6d69-defa-21d6a4e1180b
And paste it in your Bitnami Support ticket.

in part of:

[Wordpress]
Found recent WordPress plugin related error messages in the Apache error log.
`` ‘’
[Mon Jul 05 17: 05: 13.195559 2021] [proxy_fcgi: error] [pid 10967: tid
140220817078016] [client ** ip_address **: 34506] AH01071: Got error 'PHP message:
PHP Fatal error: Out of memory (allocated 41943040) (tried to allocate 6295552
bytes) in /bitnami/wordpress/wp-content/plugins/wordfence/lib/wfConfig.php on
line 696 ’

the lines of code is this, they also refer to memory:

public static function set_ser ($ key, $ val, $ allowCompression = false, $ autoload = self :: AUTOLOAD) {
/ *

  • Because of the small default value for max_allowed_packet and max_long_data_size, we’re stuck splitting
  • large values ​​into multiple chunks. To minimize memory use, the MySQLi driver is used directly when possible.
  • /

global $ wpdb;
$ dbh = $ wpdb-> dbh;
$ useMySQLi = (is_object ($ dbh) && $ wpdb-> use_mysqli && wfConfig :: get (‘allowMySQLi’, true) && WORDFENCE_ALLOW_DIRECT_MYSQLI);

if (! self :: $ tableExists) {
return;
}

self :: delete_ser_chunked ($ key); // Ensure any old values ​​for a chunked value are deleted first

if (self :: canCompressValue () && $ allowCompression) {
*$ data = gzencode (serialize ($ val)); / this is 696 */
}
else {
$ data = serialize ($ val);
}

if (! $ useMySQLi) {
$ data = bin2hex ($ data);
}

In the past times I did not get the error in: Wordpress: Found possible issues

Before in wordfence if I got bot attacks (there were many) and they told me what country they were from, now it only tells me accesses of registered users.
Also change the address of the default WP page: / wp_login. another change I made was: Stop XML-RPC Attack