My website is unexpectedly closed the connection

Keywords: WordPress - Google Cloud Platform - Technical issue - Other

bnsupport ID: 1e1289ba-001e-d289-f82c-d587ade77064

bndiagnostic output:

? Apache: Found possible issues
? Mysql: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/administration/use-pagespeed/#disable-pagespeed
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/disable-binary-logging-mysql/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
My website at www.onvglobal.com is not showing up as usual. Its error message, comes back as www.onvglobal.com unexpectedly closed the connection. I ran the Bitnami diagnostic tool it returns many different error ranging from pagespeed and my disk space being 53% full. I just want to figure out what the solution is.

Hello @chetd90,

Did you check the suggestions from the support tool?

[Apache]

Found recent Pagespeed related error messages in the Apache error log:

[Wed Jan 05 16:47:08.679439 2022] [pagespeed:error] [pid 25255:tid 140318527715072] [mod_pagespeed **ip_address**-0 @25255] PageSpeed Serf fetch failure rate extremely high; only 227 of 639 recent fetches fully successful; is fetching working?

We suggest disabling pagespeed and check if that improves the behavior. Please check the following guide to disable Pagespeed:

https://docs.bitnami.com/general/apps/wordpress/administration/use-pagespeed/#disable-pagespeed

Found recent error or warning messages in the Apache error log.

[Wed Jan 05 03:38:49.640410 2022] [core:error] [pid 17452:tid 140319509169920] [client **ip_address**:52720] AH00126: Invalid URI in request POST /cgi-bin/.%2e/.%2e/.%2e/.%2e/bin/sh HTTP/1.1
 [Wed Jan 05 12:41:51.669366 2022] [core:error] [pid 22775:tid 140319467206400] [client **ip_address**:59688] AH00126: Invalid URI in request POST /cgi-bin/.%2e/.%2e/.%2e/.%2e/bin/sh HTTP/1.1

Please check the following guide to troubleshoot server issues:

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

A high number of incoming requests originate from one or more unique IP addresses. This could indicate a bot attack. The following guide shows how to check for and block suspicious IP addresses.

https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

[Mysql]

The “/opt/bitnami/mysql/data” folder is using 53% of total disk space.

2 /opt/bitnami/mysql/data/performance_schema 39918 /opt/bitnami/mysql/data/bitnami_wordpress 1 /opt/bitnami/mysql/data/sys 1 /opt/bitnami/mysql/data/#innodb_temp 1 /opt/bitnami/mysql/data/mysql 40626 /opt/bitnami/mysql/data

In most cases this is due to binary logging. Please check the following guide to disable it.

https://docs.bitnami.com/general/apps/wordpress/troubleshooting/disable-binary-logging-mysql/

Ok, I was attempting to disable pagespeed using http.conf and for some reason I can’t save the file. I guess I have to change the permissions on the file.

You probably need to use “sudo” when editing the file.

Yeah, I was missing the sudo. My bad, but disabling pagespeed didn’t exactly solve my problems. I will try the other solutions presented.

Ok, I may have found the problem. There seems to be a IP address that keeps trying to access my site here is a screenshot of the access log:

Ok, I tried all of the proposed solutions from the diagnostic tool. Accept for reading the error log but I will do that later. The problem with my might be a domain issue will into that later.

Please take a look at this guide:

https://docs.bitnami.com/google/apps/wordpress/troubleshooting/deny-connections-bots-apache/