My website is down while server is okay. I can use SSH

Keywords: WordPress - AWS - Technical issue - Other
Hello. I’m facing that kind of problem often. I have a very good server and I think it doesn’t connect with that.

This problem appears and disappears from time to time, it could be a plugin conflict, or something else … can you help me?

I also use the CDN and get an error of 522. Here is the site -

I’d like to use this command - sudo /opt/bitnami/bnsupport-tool, but I get this error

Unable to initialize installer.
Is /tmp writable ?
Is SELinux enabled? You may need to disable it temporarily
Please see below for details

Unable to initialize installer.
Is /tmp writable ?
Is SELinux enabled? You may need to disable it temporarily
Please see below for details

This usually means that your instance doesn’t have enough disk space, can you check that?

Oh, you are right И used this command - df -hT /dev/xvda1 and it showed that i used 78Gb out of 78.

I don’t think I could waste that much space. Can you help with a command that could delete unnecessary files, can this still be a virus?

I used the command line to figure out that my WordPress website weighs 6 GB, but the server is 75 GB busy. I checked and made sure the opt/bitnami path is 75gb.

Except for the 3 folders that showed that I had no permission to enter. The rest weighed very little.

du: cannot read directory '/ opt / bitnami / letsencrypt / accounts': Permission denied
du: cannot read directory '/ opt / bitnami / mysql / data': Permission denied
du: cannot read directory '/ opt / bitnami / var / data': Permission denied

I’m pretty sure one of these files, or all of them combined, weighs 75GB. How can I delete unnecessary files if I do not have access and I cannot get it even through ftp.

Hi @InterAmazon,

To get the size of each folder inside the installation one, you can run these commands

cd /opt/bitnami
sudo du -h -d 1

If the MySQL’s folder is the one with more space, that’s probably because of the binary logging. The application is probably accessing the database so many times and all the actions are noted in those files. You can purge those files by checking the official documentation

You can also install optimization plugins like the wp-optimize to improve the performance of the server

Happy to help!

Was my answer helpful? Click on :heart:

After using sudo du -h -d 1 i got this.


I can not enter to my site so I cannot install that plugin. Are there any commands to clean some space in mysql? I cant do anything with website.

So I tried to put this command in SSH - mysql> PURGE BINARY LOGS BEFORE '2020-08-02 22:46:26';

But I got this -bash: PURGE: Permission denied

If possible, can you help me with commands to clear the mysql?

To remove binaries first I need to run mysql> show binary logs;

But I get an error

mysql.bin: [Warning] World-writable config file '/opt/bitnami/mysql/my.cnf' is ignored.

I tried everything to delete binary logs, but nothing helped, can you help with commands?

Did you log into your database as root to run the purge command?

Oh. I entered to mysql with this command - root@ -L 3306: -N & after that i used this - mysql -h -P 3306 -u bn_wordpress -p and after that i enered my password.

But after PURGE BINARY LOGS BEFORE '2020-08-02 22:46:26'; i get this error:

ERROR 1227 (42000): Access denied; you need (at least one of) the SUPER or BINLOG_ADMIN pr
ivilege(s) for this operation

Can I get instruction to purge it all quickly and disable binlogs forever?

Try accessing as root:

mysql -h -P 3306 -u root -p

And use the password in your ~/bitnami_credentials file.

When I type show binary logs; nothing is coming up. I have to see table with binary log names to purge it, but instead I see only empty rows which i can fill with letters.

Is there any command to purge all at once and disable it?

I fixed problem connected with binlog, but the ./data in the mysql folder is still awfully large - 33 GB. When my whole site weighs only several GB.

How can I get rid of these extra files? If I do not have any rights to do anything with DATA file. I could not even change the rights in FTP.

Try using this plugin to clean up your tables:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.