My website crashed and apche restart fixed

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Services (Apache, MariaDB, MySQL…)

bndiagnostic ID: 3f75fa23-0166-e062-a21c-0502389bcfad

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
? Php: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/
https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-processes/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
I want to know why the website crashed the server having 8 gb memeory

Hi @gaurav3,

This is strange, you have a big machine and the number of processes PHP can launch should be high. However, it’s only launching 5 processes

php/etc/bitnami/common-large.conf
7:pm.max_children=50

php/var/log/php-fpm.log
1:[10-Apr-2022 09:50:26] WARNING: [pool www] server reached max_children setting (5), consider raising it

Could you please run the following commands in the instance to get more info?

cd /opt/bitnami
sudo egrep -Ri max_children --exclude=php-fpm.log

Hi thanks it was 5 was max children , i raised it to 10 , what would be a good figure to raise it ot ?

That depends on the application and the requests you are receiving. I suggest you monitor the requests you receive and the PHP-FPM’s log to see if you need to increase the value again.

Just want to know for what this file is php/etc/bitnami/common-large.conf
I see max children as 50 in this file
and what is the file to change the max children

please also suggest any monitoring technique or tool for the requests

I have done this in the dymanic file as my settings for pm is dynamic, can you tell me how to test the new settings like how t check it is set?

21-Apr-2022 05:44:44] WARNING: [pool www] server reached max_children setting (5), consid
er raising it
bitnami@ip-172-26-5-212:~$

it is agan showing this error

You will need to monitor the PHP-FPM’s log file

sudo tail -f /opt/bitnami/php/var/log/php-fpm.log

Can you run these commands? You can change the max_childen parameter in those files and restart the services for the changes to take effect

cd /opt/bitnami
sudo egrep -Ril max_children *

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.