My redirection page is not loading as supposed to

Keywords: WordPress - Bitnami Cloud Hosting - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: 7fdc82f4-b910-ce7b-dd8f-d6166dee9d18

bndiagnostic output:

? Apache: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
I have a root page on primuslaundry.com that redirects to primuslaundry.com/en but it’s not loading anyway. Maybe that’s related to be something on server, isn’t?

Hello @alliancelsppc,

I don’t know if I fully understood your issue. My understanding is that you want to redirect your root page to DOMAIN/en, isn’t it? This Apache documentation could help you with that:
https://httpd.apache.org/docs/2.4/rewrite/remapping.html

Regards

Hello!
I tryed it on /opt/bitnami/apps/wordpress/htdocs/.htaccess without success.
I know there are some other places with htaccess; which one should I modify?

This is not an uncommon error. It typically indicates you need to clear your browser’s cache in order for updates or new settings to be detectable. You can always try another web browser if you are still having this issue with the initial one.

Hello @alliancelsppc,

By default, we disable .htaccess files for security and performance reasons. You can find more info in the link below:
https://docs.bitnami.com/aws/apps/wordpress/administration/use-htaccess/

We include these files’ content into the /opt/bitnami/apache2/conf/vhosts/htaccess/APPNAME-htaccess.conf file.

If you place the code into APPNAME-htaccess.conf (or any loaded .conf file) and restart Apache, the result should be the same as adding it to any .htaccess file. Note that you need to add the code between Directory tags only if you use a .conf file since .htaccess are applied in the folder where they are placed. Also, it is necessary to restart Apache in order to apply the changes.

sudo /opt/bitnami/ctrlscript.sh restart apache

Regards

I changed that, but it’s still not redirecting; Can you help further?

Hi @alliancelsppc,

That’s a basic question about redirections in Apache, you can use the lines in this page to perform the redirection

https://www.jamescoyle.net/how-to/1424-apache-redirect-root-url-to-subfolder

You can either add them to the htaccess.conf file or to the wordpress files under the /opt/bitnami/apache2/conf/vhosts/ folder.

Hi!
I cannot see this file/folder at my aplication; Screen Shot 2021-11-29 at 08.32.07