My magento doesnt work

Keywords: Magento - Google Cloud Platform - Technical issue - Other
Description:
I have installed a tempalte and it was asking for elastic search i alsoi installed it but now the website does not work. i runned the bitnami tool this is the code
dad00436-36d5-38ef-9b42-ec818cff4ab1

Hi @thery,

Thanks for using Bitnami.

I have installed a tempalte and it was asking for elastic search i alsoi installed it but now the website does not work.

We already include ElasticSearch in our cloud images to be used with Magento. Can you tell us how did you install it? If you were using the system packages (i.e. apt-get instal...), please remove it as it is not needed.

I also see some errors in the Magento logs, not sure if related to the plugin you installed. Can you check it? They are located at /opt/bitnami/magento/var/log/

Yes I used apt get ins …
So how can I activate it also I’m trying to install the claue template and it needs the elasticsearch I’ve tried to install it 3 times and in all of them I got the same mistake and the cloud machine frozen so I deleted the machine and create a new one and it happened again and again.

Hi @thery,

Can you give us any link to the plugin/theme you are having issues with? Do you know if that component supports the Magento and Elasticsearch versions included in the machine? Can you also ask the plugin developers for further help on how to debug this?

This is the link https://themeforest.net/item/claue-clean-minimal-magento-2-theme/20155150

Hi @thery,

Thanks for the link. You are using a paid theme and unfortunately, we can’t test it. Can you check your issue with the theme developers? They should be able to help you debugging it. We also recommend you to check all the components included in the Bitnami installation are supported by the theme (PHP, Magento, MySQL, ElasticSearch, Apache…).

Ok, if you want I can send it to you (theme) just give me your email address

Hi @thery,

Unfortunately, we can’t test premium themes. Another user having a similar issue solved it by setting the composer memory limit. Can you check if this helps you?

Apart from that, I think it is a good idea to check those issues with the themes developers. They must be able to provide you with better support on their product than we can

I’ll check it out.
Só I just started a new instance and the only thing that o did there was create a new website and tadaaaaa

Error 503 Backend fetch failed

Backend fetch failed

Guru Meditation:

XID: 33129

Varnish cache server

AGAIN…
Please tell me how to increase the varnish http_resp_hdr_len I read on a website that doing it will solve the problem however I can’t find the file to do it in the bitnami machine. That file magento.vcl doesn’t have this file or any other from this kind of configuration

Hi @thery,

I launched a fresh new Magento server from our launchpad and I was able to create a new website, store and store views without issues. However, I don’t have enough knowledge about Magento and I don’t know how to visit that website. Can you help me with that?

Screen Shot 2021-05-06 at 12.00.38

About the Varnish option you want to add, you can do it in the /opt/bitnami/scripts/varnish/start.sh file in the line that is calling the varnishd. For example

"${VARNISH_SBIN_DIR}/varnishd" "${varnish_args[@]}" -p http_resp_hdr_len=65536

After that, restart Varnish for changes to take effect.

sudo /opt/bitnami/ctlscript.sh restart varnish

You can check the new argument was added with the next command

$ sudo ps aux | grep -i varnish

varnish  14825  0.2  0.2 750564  9880 ?        SLl  10:23   0:00 /opt/bitnami/varnish/sbin/varnishd -j unix,user=varnish,ccgroup=varnish -a :80 -f /opt/bitnami/varnish/etc/varnish/magento.vcl -P /opt/bitnami/varnish/var/varnish/varnishd.pid -S /opt/bitnami/varnish/etc/varnish/secret -s malloc,256M -p http_resp_hdr_len=65536

heyy thanks for your help.
to access the stores you need to change the url, follow this tutorial
https://www.youtube.com/watch?v=0aU5viBd1AE

about the varnish im getting an error
“${VARNISH_SBIN_DIR}/varnishd” “${varnish_args[@]}” -p http_resp_hdr_len=65536
-bash: /varnishd: No such file or directory

Hi @thery,

Notice the needed line is included in the script you shared in your previous post, around the end of the file. You only need to include the -p http_resp_hdr_len=65536 part to that line using the text editor of your preference, save the file and restart Varnish.

Thanks for the information about the Magento website. I will give it a try and let you know if I reproduce your issue

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.