My cert is valid, but all uploads are Mixed content

Keywords: WordPress - Bitnami Cloud Hosting - How to - Secure Connections (SSL/HTTPS)

Description:
Hi folks. As said, my cert is valid, but in the wordpress settings, my URL is still showing as http://domain.co.uk instead of https://

Also, whenever I upload media to the site, it’s going up as http giving lots of mixed content errors.

Have I missed a step?

Hi @darranoshea,

Have you configured WordPress to use your custom domain name? If not, please configure it as explained in the next guide but using https:// for the URL instead of http.

https://docs.bitnami.com/bch/apps/wordpress/administration/configure-domain/

If you have already configured it and you continue having issues, please open a new technical issue thread when clicking the + New Topic button. It is possible that you need to clean your browser cache to see the new workflow

Hi gongomgra!

I’ve tried the link you suggested!

Using Approach A, I’m just getting the following errors.

darranoshea@wordpress-3-vm:~$ /opt/bitnami/wordpress/wp-config.php
-bash: /opt/bitnami/wordpress/wp-config.php: Permission denied
darranoshea@wordpress-3-vm:~$ sudo /opt/bitnami/wordpress/wp-config.php
sudo: /opt/bitnami/wordpress/wp-config.php: command not found
darranoshea@wordpress-3-vm:~$

They are the files in the dir. Is it right that my wp-config file is a link?? (I’ve been learning some basic linux cli stuff over the last few weeks)

-rw-rw-r-- 1 bitnami daemon 405 Jun 2 10:19 index.php
drwxrwxr-x 2 bitnami daemon 4.0K Jun 2 11:13 licenses
-rw-rw-r-- 1 bitnami daemon 20K Jun 2 10:19 license.txt
-rw-rw-r-- 1 bitnami daemon 7.2K Jun 2 10:19 readme.html
drwxrwxr-x 2 bitnami daemon 4.0K Jun 2 16:13 tmp
-rw-rw-r-- 1 bitnami daemon 7.0K Jun 2 10:19 wp-activate.php
drwxrwxr-x 9 bitnami daemon 4.0K Jun 2 11:13 wp-admin
-rw-rw-r-- 1 bitnami daemon 351 Jun 2 10:19 wp-blog-header.php
-rw-rw-r-- 1 bitnami daemon 2.3K Jun 2 10:19 wp-comments-post.php
lrwxrwxrwx 1 root root 32 Jun 8 16:09 wp-config.php -> /bitnami/wordpress/wp-config.php
-rw-rw-r-- 1 bitnami daemon 2.9K Jun 2 10:19 wp-config-sample.php
lrwxrwxrwx 1 root root 29 Jun 8 16:09 wp-content -> /bitnami/wordpress/wp-content
-rw-rw-r-- 1 bitnami daemon 3.9K Jun 2 10:19 wp-cron.php
drwxrwxr-x 25 bitnami daemon 12K Jun 2 11:13 wp-includes
-rw-rw-r-- 1 bitnami daemon 2.5K Jun 2 10:19 wp-links-opml.php
-rw-rw-r-- 1 bitnami daemon 3.3K Jun 2 10:19 wp-load.php
-rw-rw-r-- 1 bitnami daemon 44K Jun 2 10:19 wp-login.php
-rw-rw-r-- 1 bitnami daemon 8.4K Jun 2 10:19 wp-mail.php
-rw-rw-r-- 1 bitnami daemon 21K Jun 2 10:19 wp-settings.php
-rw-rw-r-- 1 bitnami daemon 31K Jun 2 10:19 wp-signup.php
-rw-rw-r-- 1 bitnami daemon 4.7K Jun 2 10:19 wp-trackback.php
-rw-rw-r-- 1 bitnami daemon 3.2K Jun 2 10:19 xmlrpc.php

Thanks.

Hi @darranoshea,

Please find my comments below

Notice those commands aren’t valid for editing a file, you need to use a text editor like nano. Please check our guide for this

https://docs.bitnami.com/bch/faq/administration/edit-privileged-files/

If after editing the file you continue having issues, please open a new technical issue thread in our forum.

Thank you gongomgra! Issue seems to be resolved after that!

Hi @darranoshea,

Thanks for the info. I’m glad you fixed your issue! We will close this thread as solved. Please do not hesitate to open a new one with any other questions you may have.