Multiple HTTP to HTTPS redirect solutions not working

Keywords: Moodle - AWS - Technical issue - Secure Connections (SSL/HTTPS)
bnsupport ID: 66d6d267-7a94-2224-c4df-e4bb80d3070b
Description:
I am running a Moodle 3.9.4 instance on AWS EC2, it has been upgraded several times starting from a Moodle 2.3 instance which was originally launched in 2012. In October it was moved to HTTPS which works fine if the URL is entered as HTTPS or without a transfer protocol, just the domain name. If HTTP is entered in the URL however the connection times out.

I have followed the directions in several articles and threads including modifying the bitnami.conf according to option B in this article: https://docs.bitnami.com/aws/apps/moodle/administration/force-https-apache/ and restarting services. I did verify that I am using a self-contained installation.

I have also tried adding HTACCESS to the root directory in /opt/bitnami/apps/moodle/htdocs as outlined here: https://moodle.org/mod/forum/discuss.php?d=348822. I also tried adding HTACCESS here: /opt/bitnami/apache2/htdocs as this was the original root directory.

I even tried doing a redirect using an HTML meta tag in an index file. I think the problem may be that my original root directory was in /opt/bitnami/apache2/htdocs which uses an HTML redirect to get to the /moodle/htdocs root directory.

Hi @mns271,

It seems that port 80 is closed in the firewall configuration and that’s why you get a timeout error. Please review this guide and ensure ports 22, 80 and 443 are open in the instance’s security groups configuration.

https://docs.bitnami.com/aws/faq/administration/use-firewall/

Happy to help!


Was my answer helpful? Click on :heart:

1 Like

That was it Jota. I assumed I had opened it when I created the security group, but I apparently only opened 443 and 22. Thanks very much, sometimes we look so deep into a problem we miss the simple things.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.