[Multiple domain] Newly added vhost.conf is not working

Keywords: LAMP/MAMP/WAMP - Google Cloud Platform - Technical issue - Application configuration

bnsupport ID: 57825295-fb8d-49eb-1a1a-7e67368edd81

bndiagnostic output:

? Apache: Found possible issues
? Connectivity: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: The documentation did not make any significant change

Description:
I wanted to make my system to handle multiple domains. So I added refro-vhost.conf and refro-https-vhost.conf But after adding vhost file my existing website http://www.refro.in stopped working and giving error :The requested resource could not be loaded.:

Hi @pathak.ashu2003

Thanks for using Bitnami LAMP!

I have briefly checked your configuration and I can’t find the refro-https-vhost.conf file. In a similar manner, your existing website does seem to work as of now. Were you able to solve your issue?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

HI, Thanks for your quick response. Problem was that SSL cert, SSL key path was wrong in domain1-https-vhost.conf. This file should be

<VirtualHost *:443 _default_:443>
  ServerName www.domain1.in
  ServerAlias domain1.in
  SSLEngine on
  SSLCertificateFile "/opt/bitnami/apache/conf/bitnami/certs/server-domain1.crt"
  SSLCertificateKeyFile "/opt/bitnami/apache/conf/bitnami/certs/server-domain1.key"
  DocumentRoot /opt/bitnami/apache/htdocs/domain1
  <Directory "/opt/bitnami/apache/htdocs/domain1">
    Options -Indexes +FollowSymLinks -MultiViews
    AllowOverride All
    Require all granted
  </Directory>
</VirtualHost>

domain1-vhost.conf file:

<VirtualHost *:80 _default_:80>
  ServerName www.domain1.in
  ServerAlias domain1.in
  DocumentRoot /opt/bitnami/apache/htdocs/domain1
  <Directory "/opt/bitnami/apache/htdocs/domain1">
    Options -Indexes +FollowSymLinks -MultiViews
    AllowOverride All
    Require all granted
  </Directory>
</VirtualHost>

Similarly I created domain2-vhost.conf, domain2-https-vhost.conf
now everything is fine.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.