MS Azure Image is missing in the marketplace?

Hi there,

i try to deploy your guacamole image in the azure cloud. But it seems that the image is missing in the marketplace. If i try to deploy the vm through the azure portal i get the information that the image is not available in this location. But this message is posted for each location!

If i try to get the image name trough the az cli i get nothing back:

$  az vm image list --offer guacamole --all --output table
   
$  

I think after you update the new image something gone terrible wrong with the upload of this image version. Maybe you should consider adding multiple versions of the image into the marketplace of azure!


Can you help me and add the image again in the marketplace?

Thanks a lot and greetings

And if i list all bitnami images in azure with:
$ az vm image list --publisher bitnami --all --output table
i couldn’t find the guacamole image .

PS. why i cannot edit my postings? :smiley:

Hi immae,

First of all thanks for reporting this issue and for the detailed triage.

Seems Guacamole is not the only affected solution. We are contacting Azure about this, as it seems they might be experiencing a bug or issue that makes those solutions unavailable after a successful publishing.

We’ll keep you posted here.

Thanks,

Jose

1 Like

Hello @josvaz
Thanks. I don’t mean to annoy you, but do you have any more information or status on Azure? How much longer is this issue going to be there? :smiley:

Hi Immae,

Sorry, but I can’t currently give you a completion estimation. As soon as we have news from the Azure team we will update this case.

In the meantime, if you just want to check out our Guacamole image in Azure and don’t mind not using it from the Marketplace you can use the same one from our launchpad:
https://azure.bitnami.com/launch/guacamole
Our Launchpad is free, so you can create an account if you don’t have one already at no cost.

Thanks,

Jose

Hi Immae,

We got word from Azure. Seems there was an outage in their service and they are repairing throughout this week. They expect the images to be available from Monday.

Where you able to launch from our launchpad in the meantime?

Thanks,

Jose

hi josvaz,
ok thanks for the information. i doesn’t used the launchpad because i creating my vms with terraform scripts.

Greetz

Hi Immae,

If you are using Terraform and won’t want to wait for the Marketplace fix you might like to use the VHD directly and create an image in your own account from it.

Our Guacamole image VHD is:
https://bitnamibuilds.blob.core.windows.net/bitnami-src-vhds/bitnami-guacamole-1.1.0-17-r06-linux-debian-9-x86_64-nami.vhd

Let us know if you need further instructions, like how to make that a managed image in your Azure account.

Anyway, hopefully the regular marketplace image should be usable again next week according to Azure.

Thanks,

Jose

Hi Immae,

Azure told us they had fixed this, and I have just verified I can launch a Guacamole instance from the marketplace image in the portal. I also tried another solution that was also affected last week.

Can you give it a try and confirm all is fixed on your side?

Thanks,

Jose

Hi josvaz,
yes the fix is working for me too!
Thanks a lot for your help and the reporting!
Greets
Immae

Thanks for confirming Immae!

I will close this topic now, but don’t hesitate to contact us again if you need anything.

Jose