Mount /opt/bitnami volume on OS X VN failed

Keywords: Redmine - OSX VM - Technical issue - Application configuration

bnsupport ID: 6086b6e3-066d-2b37-4d25-2d160c094842

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
? Connectivity: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
Hi Support,

Currently I run Bitnami Redmine 4.1.1-1, but triggered by the discussion around log4j I was motivated to upgrade to the latest Redmine stack version. While generating the backup files, I ran into trouble. Formerly, I used to mount the VM volume such that I could copy the zipped tar files of the files, plugins and database backups on some hard drive storage. To do so, I mounted the /opt/bitnami volume by using the mount command from the Redmine GUI.

However, this does not work after upgrading to Mac OS X 12.0.1 Monterey. The error message in the log reads:

ERROR: Cannot mount volume “root”: cannot mount “root”: mount_nfs: can’t mount with remote locks when server (nnn.nnn.nn.n) is not running rpc.statd: RPC prog. not avail
mount: ~/.bitnami/stackman/machines/redmine/volumes/root failed with 74

(here I replaced my personal data with ‘nnn’ and ‘~’). Is there any possibility to mount without the logging, so that I can export the data?

I found this related blog post and would try to use the described mount options (https://forums.macrumors.com/threads/since-upgrading-to-big-sur-i-can-not-longer-mount-remote-nfs-drives.2274862/)

Thanks in advance for any help.

OK, I helped myself, using scp to copy files from and to the VM. I could then upgrade the stack and the issue does not occur any longer in version 4.2.3-27 of the Redmine Stack for Mac OS X VM. The issue is resolved for me and I need no further support. I am sorry for the inconvenience caused by my inquiry.

Thanks anyways, and a very peaceful holiday season.

1 Like

I’m really glad to hear you managed to solve the issue!

Enjoy and happy holidays! :slight_smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.