(mostly) new installation of Redmine - several errors - Internal error when accessing project settings, can't attach

Keywords: Redmine - Windows - Technical issue - Permissions
bnsupport ID: 0d1e5682-bb7e-b451-f497-d6c7b726ff53
Description:
Sorry for the long winded title, but here’s the issues.

  • This is my first time doing anything in Redmine with this project (ever) - I have migrated from a very old server to a new one. I got our files, and afaik got all of the pertinent data from the DB to the new one.

  • We are getting Internal error when accessing settings on any issue or project, unable to add or change anyone from the assigned people.

  • We can’t upload attachments to issues

  • And even though I have my email configured in the DB and in the config yml, no emails are going out.

I can provide any needed finer details as needed.

http://redmine.us.scytl.net/projects/connect-support/settings brings me to:

image

And if I try to add an attachment to an issue:

image

and it doesn’t attach, nor send an email.

Hi @cj.boat,

If you migrated from an old installation to a new one, you probably need to update the database schema and clear the cache to finishing the migration. We have this guide in our documentation that explains the full process to migrate and upgrade Redmine, did you take a look at it?

https://docs.bitnami.com/installer/apps/redmine/administration/upgrade/

Thanks

Is there something in there on how to do this on a Windows installation? Sadly, I am a DBA (don’t ask) and am pretty limited on server knowledge.

When trying to troubleshoot this, I now can’t even get my thin_redmines to start:
image

There were two plugins from our previous installation that I thought I needed, in D:\Bitnami\redmine-4.0.3-3\apps\redmine\htdocs\plugins that I removed, and now get 503 errors as well, when I could get those thin_redmines working but now they won’t start.

Hi @cj.boat,

Can you run the Bitnami Support tool again so we review the content of the different logs again?

https://docs.bitnami.com/installer/how-to/understand-bnsupport/

Please note that you need to paste the code outputted by the tool in your reply.

hi @jota

The support bundle was uploaded successfully to the Bitnami servers. Please copy the following code:
6e8b4ed9-3c0c-bab3-8996-7f152a88f3ff
And paste it in your Bitnami Support ticket.

I have everything else working other than email, which is an Office365 setup, and here is my default from our configuration.yml

default configuration options for all environments

default:

Outgoing emails configuration

See the examples below and the Rails guide for more configuration options:

http://guides.rubyonrails.org/action_mailer_basics.html#action-mailer-configuration

email_delivery:
delivery_method: :smtp
smtp_settings:

 address: smtp.office365.comm
 port: 587
 domain: example.net
 authentication: :login
 user_name: no-reply@scytl.net
 password: <EMAIL PASSWORD HERE>

I also have this in my Production env in there as well, just because when I did a search it said to put in both Default and Production:

specific configuration options for production environment

that overrides the default ones

production:
email_delivery:
delivery_method: :smtp
smtp_settings:

 address: smtp.office365.comm
 port: 587
 domain: example.net
 authentication: :login
 user_name: no-reply@scytl.net
 password: <EMAIL PASSWORD HERE>>

this still doesn’t work.

Hi @cj.boat, in your error logs I can see this:

[ActiveJob] [ActionMailer::DeliveryJob] [f911c47d-2d12-4ebf-a5d4-874c043f0062] Email delivery error: getaddrinfo: No such host is known..

I also see you configured this address:

 address: smtp.office365.comm

It should be:

 address: smtp.office365.com

I hope that fixes your issues!

I can’t believe I missed that, but sadly it is still not working.

Hi @cj.boat, if it doesn’t work yet, could you run the Bitnami Support tool again?

Thanks!

Done: 3401c9b8-249d-8ad9-6a48-91d7e6b7ee7d

I am also getting an internal server error on the Roadmap:

http://redmine.us.scytl.net/projects/electronic-ballot-delivery/roadmap

image

In regarding to this Internal error, it appears only on certain projects, does anyone know why it would internal error on some projects but not others?

I am noticing it has an error of :

ActionView::Template::Error (undefined method `is_closed?' for nil:NilClass):
    15: <% end %>
    16: 
    17: <% if version.visible_fixed_issues.count > 0 %>
    18:     <%= progress_bar([version.visible_fixed_issues.closed_percent, version.visible_fixed_issues.completed_percent],
    19:                      :titles =>
    20:                        ["%s: %0.0f%%" % [l(:label_closed_issues_plural), version.visible_fixed_issues.closed_percent],
    21:                         "%s: %0.0f%%" % [l(:field_done_ratio), version.visible_fixed_issues.completed_percent]],

I have no idea what that means.

Hi @cj.boat,

Are your Thin servers already running? Or they are still stopped?
Until all the servers are running Redmine is not going to behave correctly so the first thing I would do is fixing those services.

Is there anything meaningful in the Server Events tab in the Bitnami manager application?

For this question, I highly recommend you to check Redmine specialized forums.

@tomasp everything is running now minus this roadmap.on certain projects. When I asked in a Redmine discord, since I use Bitnami they told me to pretty much only talk here.

@cj.boat Do you mind running the bnsupport tool again?

The last thing I can see in the apache error log is that the Thin servers are not running so maybe that was hiding other errors.

c52303b6-eed3-8caa-3f34-6c4cc553f753 is the most recent BNSupport code. I just restarted everything, and I can assure you the thin servers were running as of the last time I ran the support tool as well.

image

Thanks @cj.boat!

Now it is clear that there aren’t any error in the apache error log.

Regarding the 500 Internal Error in some projects, are you able to identify any common pattern between those projects? Maybe they were created by the same user, they have configured the same properties, …

I found some old similar issues in the Redmine forum but unfortunately they don’t have any answer: