Migrate RedmineAgilePlus 4.1.1-6 to Redmine 4.2.2 with agile plugin

Keywords: Redmine - Installers - Technical issue - Upgrade

bnsupport ID: c22165fd-1a21-a57e-1ff2-858fe294dc94

Description:
We are currenty using redmineagileplus 4.1.1-6 and want to upgrade to Redmine 4.2.2 latest version.

After running this command,

bundle exec rake db:migrate RAILS_ENV=production

I faced error like below table exist.

user_preference

if drop table and run db migrate again then it allows to create table but we need to migrate table that is not happening.’
Below are few other tables having the same issue.

wiki
wiki_pages
comments
wiki_contents
wiki_content_versions
time_entries
changesets

We see the below error on console

-- create_table(:user_preferences, {:options=>"ENGINE=InnoDB", :id=>:integer})
rake aborted!
StandardError: An error has occurred, all later migrations canceled:

Mysql2::Error: Table 'user_preferences' already exists: CREATE TABLE `user_preferences` (`id` int NOT NULL AUTO_INCREMENT PRIMARY KEY, `user_id` int DEFAULT 0 NOT NULL, `others` text) ENGINE=InnoDB

Hi @nmistry,

I understand you are following our guide to perform the migration right?

https://docs.bitnami.com/installer/apps/redmine/administration/upgrade/

I can see that there are similar issues (for example this one https://www.redmine.org/boards/2/topics/50880) in the Redmine forum regarding this error. Could you please take a look at them or create a new issue in the Redmine forum to get support from the Redmine’s team? Please also ensure the Agile version you have (and any other plugin you have) supports the new Redmine version you are going to upgrade to.

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.