Migrate Openproject 8.1.0 to current Version on different VM

Keywords: OpenProject - Linux - How to - Upgrade
Description:
Hello.

It’s been a while and a lot was going on, so I got stuck with a Bitnami Openproject stack on version 8.1.0 . Up to now nobody really seemed bothered by this and as always there are more pressing matters.

Now is the time, the most pressing matter became Opeproject again. I already transfered the VM containing the Opeproject stack to a new server and already installed a new VM with an Ubuntu 20.04, ready to receive the most recent Binami stack of Openproject.

But, as I see now, Mysql is gone (which my current stack is based on) and Postgresql is game now. I must admit that Linux is not my strong suit so I already kept that stack barely running (well, it still works, so…), So I’m a bit stumped now. It doesn’t help that with the change of the SQL provider the mysql part of the documentation seemed to have went out the window.

So in summery: How do I migrate my database and settings to my new VM running the most recent version (11.2.0?)?

Thank you for your help

Hi @Andarion,

Can you check the following guide for migrating data from mysql to postgres?

https://docs.openproject.org/installation-and-operations/misc/packaged-postgresql-migration/

Regards,
Michiel

It already starts with the problem that right now, I don’t know how and what to backup from my current Installation. It’s been two years since I did that when I tried to upgrade to 8.3.2 and failed.

In the past I relied on the Bitnami documentation for that, but I cannot find an old version regarding mysql versions and my ols bookmarks are no help.

The openproject documentaion gives either a special openproject command or a docker description. Since a Bitnami stack is no docker container… can I run the openproject-command somehow? I vaguely remeber that I had to do a mysql dump after somehow entering the mysql enviroment of the stack. so maybe I can run the openproject command from that envoriment too?

Hi @Andarion,

This post explains more about how to solve this issue:

Can you check if it works for you?

Regards,
Michiel

I checked, but sadly it does not work for me because the link posted in the reply there (https://docs.bitnami.com/google/apps/openproject/administration/backup-restore-mysql-mariadb/) is a dead link and I am unable to reproduce this crucial step.

Hi @Andarion,

This guide (for WordPress) which has the same steps as the one from the link:

https://docs.bitnami.com/google/apps/wordpress/administration/backup-restore-mysql-mariadb/

Could you check them?

Regards,
Michiel

Well, I finally managed to get a bump from the MySQL database.

Took me about another day to find out how to migrate mysql to postgresql.Took me about another day to get the script running. took the script about 10 seconds to completely destroy ruby. :frowning:

Hi @Andarion,

could you please elaborate? Once you migrated the database to the PostgreSQL server installed in the new server, you should be able to start all the services without breaking anything. What did you do to “destroy ruby”? Why do you say that ruby was destroyed?

I ran the migration script that came with Openproject.

Turned out to be the wrong script, I suppose it is intended when you switch from mysql to postgresql within the same Openproject installation.

Whyt I need is a migrations script from an old mysql version of opneproject to postgresql not only migrating between the two systems but also updating the structure.

I found a script here (https://github.com/opf/openproject/blob/dev/script/migration/migrate-from-pre-8.sh) which I got from there (https://docs.openproject.org/installation-and-operations/misc/upgrading-older-openproject-versions/#migrating-from-an-old-mysql-database) which is also not working.

Sadly Opneproject does not care the least. Waiting for help for nearly two weeks now. nobody replies.

Any ideas?

Hi @Andarion,

I’m afraid both migrating and upgrading is not possible. But what was the script output? Did it show any error?

Regards,
Michiel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.