Messed everything up trying to renew a SSL!

Keywords: WordPress Multisite - AWS - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: c2b51b63-7248-ee45-3ad0-a2aa34d84752

bndiagnostic output:

? Apache: Found possible issues
? Connectivity: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
Hello there, so I was trying to renew a SSL which was expired and voila!! Messed everything up doing things I probably shouldn’t have done, thinking I knew what I was doing which obviously I don’t. Now I don’t have anything and would like to get back to having my websites :slight_smile: Thanks.

Hi @mauricio

Thanks for using Bitnami WordPress Multisite!

Let’s try to get your site back and running:

  1. Perform the following modifications to your /opt/bitnami/apache/conf/bitnami/bitnami-ssl.conf
...
<VirtualHost _default_:443>
  DocumentRoot "/opt/bitnami/apache/htdocs"
  SSLEngine on
+  SSLCertificateFile "/opt/bitnami/apache/conf/bitnami/certs/server.crt"
+  SSLCertificateKeyFile "/opt/bitnami/apache/conf/bitnami/certs/server.key"
  # BEGIN: Configuration for letsencrypt
  Include "/opt/bitnami/apps/letsencrypt/conf/httpd-prefix.conf"
  # END: Configuration for letsencrypt
  <Directory "/opt/bitnami/apache/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
  </Directory>

  # Error Documents
  ErrorDocument 503 /503.html
</VirtualHost>

- <VirtualHost _default_:80>
-  DocumentRoot "/opt/bitnami/apache/htdocs"
-  # Redirect to HTTPS
-  # BEGIN: Configuration for letsencrypt
-  #Include "/opt/bitnami/apps/letsencrypt/conf/httpd-prefix.conf"
-  # END: Configuration for letsencrypt
-  #RewriteEngine On
-  #RewriteCond %{HTTPS} !=on
-  #RewriteCond %{HTTP_HOST} !^(localhost|127.0.0.1)
-  #RewriteRule ^/(.*) https://%{SERVER_NAME}/$1 [R,L]
-  # End of redirect
- </VirtualHost>
  1. Test your apache configuration and restart the service:
sudo apachectl -t
sudo /opt/bitnami/ctlscript.sh restart apache

Can you please follow the steps and report if your server was able to start up?

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

1 Like

Good morning @jcarmona,

Something so simple yet so complicated!!! :rofl:

It worked perfectly, that’s the difference between people who know, and us mortals!!

Have a great day and thank you for your help.

Mauricio

Glad to see you were able to solve your issue! We are marking the previous answer as “Solution” and this topic as “Closed”.

If you have any other questions, please do not hesitate to let us know. Feel free to create a new topic referencing this one if necessary.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart: