Localhost refused to connect. Bitnami Server Manager is not running any servers at all

Keywords: WordPress - Windows - Technical issue - Other
Description:
I have created a Wordpress website locally using the Bitnami installer. Everything was going well and I have managed to finish designing the website until something happened.

I’m not sure if it is in any way related to the issue but my computer automatically installed a Windows update, since then I cannot access the website that I created locally. It says that,

This site can’t be reached

localhost refused to connect. Try:

Checking the connection Checking the proxy and the firewall ERR_CONNECTION_REFUSED

Again, I’m not sure if this has anything to do with the update, because I have already uninstalled the updated and it’s still the same. What’s also weird is that my Bitnami managers servers aren’t running any servers, and actually there are no servers under it at all.

I am confused and lost as to how this happened and what’s the solution for this. I would appreciate any help or pointed anyone can give me.

Hi @emteleg

Thanks for using Bitnami WordPress!

What’s also weird is that my Bitnami managers servers aren’t running any servers, and actually there are no servers under it at all.

Can you please provide us with a screenshot of your Manage Servers and Application log tabs in the manager for your WordPress stack? Here is a guide that mentions such application, as well as how to control services:

https://docs.bitnami.com/installer/faq/windows-faq/administration/control-services-windows/

Additionally, we have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

Thank you so much. Please see the screenshots attached.

@jcarmona

I messaged you my code from the support tool. Thank you so much. Looking forward for your help.

Hi @emteleg,

Could you try to reinstall the services?

cd installdir
serviceinstall.bat INSTALL

Regards,
Michiel

Hi michiel, I’m very new to this, so I’m not quite sure I’m doing the right thing. I tried running the remove and install command in the use_wordpress batchfile but nothing happened. If you could please help me resolve this, that would be amazing.

Hi @emteleg,

Can you open the installation directory in the file explorer and then open a command window in that folder:

https://www.itprotoday.com/windows-10/add-open-command-window-here-windows-10-context-menu

Inside the command window, can you run this command:

.\serviceinstall.bat INSTALL

And then restart the Bitnami WordPress Window manager?

Does that change anything?

Regards,
Michiel

Hi Michiel. Thank you for the response. I have tried doing it but to no avail, there doesn’t seem to be any changes. Can you please take a loot from your end? I think I’ve sent you my code from the support tool. Thank you so much.

Hi @emteleg,

The bnsupport tool info did not gather useful information. (We are working on improving it for Windows). Can you open a cmd window and run this command to check if any services are running?

powershell -command Get-Service wordpress*

Regards,
Michiel

Hi Michiel, I have tried doing this but this doesn’t seem to do anything on my machine or to my problem

Do you think there is any other way that I can solve this?

Hi @emteleg,

Can you open the “Services” app on Windows

https://www.digitalcitizen.life/ways-access-services-windows/

and check if there are services there which name start with wordpress? You can obtain the exact name of the services by opening the properties.ini file of the WordPress installation directory.

Note: if you do not find the services, can you post the content of the properties.ini file here?

Thanks

Hi Jota, I don’t see the wordpress in the services app.

Here’s the content of the properties

[Banner]
disable_banner_file=C:\Users\Lenovo\Desktop\Wordpress/apps/bitnami/banner/disable-banner
[MySQL]
mysql_port=3306
mysql_host=127.0.0.1
mysql_root_directory=C:\Users\Lenovo\Desktop\Wordpress/mysql
mysql_binary_directory=C:/Users/Lenovo/Desktop/Wordpress/mysql/bin
mysql_data_directory=C:\Users\Lenovo\Desktop\Wordpress/mysql/data
mysql_configuration_directory=C:\Users\Lenovo\Desktop\Wordpress/mysql
mysql_arguments=-u root
mysql_unique_service_name=wordpressMySQL
mysql_version=8.0.22
mysql_database_type=mysql
[General]
installdir=C:\Users\Lenovo\Desktop\Wordpress
base_stack_name=Bitnami WordPress Stack
base_stack_key=wordpress
base_stack_version=5.6-3
base_stack_platform=windows-x64
hostname=
[Support]
installed_components=apache php mysql imagemagick wordpress
apache_logs=apache{,2}/logs/error*log logs/error_log
apache_conf=apache{,2}/conf/{*.conf,bitnami/*.conf} etc/httpd.conf apps/*/conf/ht*.conf
apache_acl=apache apache2
php_logs=php/var/log/php-fpm.log
php_conf=php/{php.ini,etc/php.ini}  php/etc/bitnami/common.conf apps/*/conf/php-fpm/*.conf
php_acl=php
mysql_logs=m{ysql,ariadb}/data/mysql{d,_error}.log var/mysql/*.err
mysql_conf=m{ysql,ariadb}/{my.cnf,my.ini} etc/my.cnf
mysql_acl=mariadb mysql
imagemagick_conf=common/lib/ImageMagick-*/config-*/{log.xml,magic.xml,policy.xml,type.xml}
wordpress_priv=apps/wordpress/htdocs/wp-config.php
[Apache]
apache_server_port=80
apache_server_ssl_port=443
apache_root_directory=C:\Users\Lenovo\Desktop\Wordpress/apache2
apache_htdocs_directory=C:\Users\Lenovo\Desktop\Wordpress/apache2/htdocs
apache_domainname=Hassan
apache_configuration_directory=C:\Users\Lenovo\Desktop\Wordpress/apache2/conf
apache_unique_service_name=wordpressApache
apache_version=2.4.46
[PHP]
php_binary_directory=C:/Users/Lenovo/Desktop/WORDPR~1/php
php_configuration_directory=C:/Users/Lenovo/Desktop/WORDPR~1/php
php_extensions_directory=C:/Users/Lenovo/Desktop/WORDPR~1/php/ext
php_version=7.4.14
[Imagemagick]
imagemagick_root_directory=C:\Users\Lenovo\Desktop\Wordpress\imagemagick
[SMTP]
smtp_host=smtp.gmail.com
smtp_port=587
smtp_user=[REDACTED]
smtp_password=[REDACTED]
smtp_protocol=tls

Hi @emteleg,

Let’s try to install the Apache service manually, please follow these steps:

  • Go to the installation directory and double click the use_wordpress.bat file
  • Run this command
"C:\Users\Lenovo\Desktop\Wordpress/apache2\bin\apache.exe" -k install -n "wordpressApache" -f "C:\Users\Lenovo\Desktop\Wordpress/apache2\conf\httpd.conf"

Do you get any error? Can you open the services app again and look for that “wordpressApache” service? Can you start it using the services app?