List display view does not consistently show the data in the field

Hello, I recently discovered that the values in my publisher field (field84) do not show consistently when I view resources in the list view. I added the field in config with $list_display_fields. i.e. The records/resources will have data in the publisher field, but only some records/resources show that value. When I click on item details, I see the publisher value just fine. I tried performing a batch edit to undo/redo the value in publisher field, but this did not show the values. The only thing that works is individually editing each record (undo/redo) which is an incredible amount of time for this bug.

I also tried reindexing fields, and changing the metadata field type to text, dropdown. Still does not show all values. It is consistent in which records it decides not to show publisher data for, though. Other records show publisher fields, but I expect all records so show the values in the publisher field!

Any thoughts in where the buy may lie, is it with the software or bitnami?
https://drive.google.com/a/kboo.org/file/d/0B4eaTa3ouboDUElNUnVjMDRyTjg/view?usp=sharing
https://drive.google.com/a/kboo.org/file/d/0B4eaTa3ouboDSjdKTlhmUkNNWU0/view?usp=sharing

Hi @archive,

Thanks for letting us know about this. As a first step, we recommend stating the issue in the official user forums of ResourceSpace, as they have a more specific knowledge of the application and this issue could be a bug in the application itself.

Additionally, it seems we don’t haver permissions to access the document links at the bottom of your post. Are they meant to be public?

Best regards,
Alvaro Recio