Liferay file not found in apache-tomcat folder

:warning: IMPORTANT, please fill the questions

We assume you are using Bitnami to deploy your application.

  • Which version of the application are you using?: latest version

  • Please choose how you got the application: Installer (Windows, Linux, macOS), cloud image (AWS, GCE, Azure, …) or VM (VMDK, VBOX): AWS

  • Have you installed any plugin or modified any configuration file?: yes

  • Describe here your question/suggestion/issue (expected and actual results): I am trying to use my Iframe content in the liferay website. Since, I couldn’t find the original file, I’ve created a file in the “/opt/bitnami/apache-tomcat/webapps/ROOT/WEB-INF/classes” directory and added the following line “”. But when I tried to access the Iframe, its getting denied because there are two conflicting values for the iframe options property one with the default deny and the other with /web/url/home/ value. Is there any way to find the original file or to fix this issue?

  • Steps to reproduce the issue (if relevant):

  • Copy the apache log (if relevant):


Hi @spinnapreddy,

Thank you for using Bitnami. Could you please let us know how you are testing the changes in the configuration files of Liferay? We are going to review the information you provided and the configuration of our Liferay stack and we will update this thread as soon as we have more information.

Apart from that, are you following any guide to change the configuration of the application?


@jota I couldn’t find the file in /opt/bitnami/apache-tomcat/webapps/ROOT/WEB-INF/classes/ directory. So, I’ve edited the portal-impl.jar/ file present in /opt/bitnami/apache-tomcat/webapps/ROOT/WEB-INF/lib directory and changed the variable value to false to enable the Iframe content. How to make the server read these changes and act accordingly? The server is redirecting to the same origin (default) again and again.

Hi @spinnapreddy

We don’t clearly know what you are trying to achieve when configuring that. Please note that we also include Apache and it takes care of redirecting the requests to Apache-Tomcat. Could you please let us know what you are trying to achieve and the guide you are following so we can let you know how to solve that in the Bitnami stack?


@jota I’m trying to enable Iframe content on Liferay Server. I’ve added this line “” in the system.properites file. I’ve used a couple of threads on liferay and official liferay documentation for reference.


Unfortunately we were unable to reproduce your issue. We were able to add an iframe just fine. In our case, we did the following:

  1. Create a collection in Page Fragments.
  2. Add an iframe to our local URL (e.g. http://localhost) and publish it.
  3. Add the Page Fragment to a Page.
  4. Check the iframe in the site. In our case it worked.

If you did not follow these steps, could you let us know how you added iframes? This way we can try to reproduce the issue in the same way.
Please give detailed instructions on each step (e.g. Admin -> Sidebar -> Click on Page Fragments -> etc.).


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.