Liferay fresh install cannot login as default admin

:warning: IMPORTANT, please fill the questions

We assume you are using Bitnami to deploy your application.

  • Which version of the application are you using?:
    Latest Version: Liferay CE 7.0.2-1-r28 on Ubuntu 14.04.3 (https://aws.amazon.com/marketplace/pp/B00NPHLT1E/ref=ads_be0bee02-5a6e-1500471195#)

  • Please choose how you got the application: Installer (Windows, Linux, macOS), cloud image (AWS, GCE, Azure, …) or VM (VMDK, VBOX): AWS Marketplace (US-West Oregon)

  • Have you installed any plugin or modified any configuration file?:
    No

  • Describe here your question/suggestion/issue (expected and actual results):
    Expected: Logging into liferay as the default admin for the first time using the sign in link (top right) I expect to see the user agreement form and then be logged in (seeing the admin menu and toolbar).

Actual: When I try to login as the default liferay admin using the sign in link (top right) it goes to /web/guest/home?p_p_id=com_liferay_login_web_portlet_LoginPortlet&p_p_state=exclusive&p_p_mode=view&_com_liferay_login_web_portlet_LoginPortlet_javax.portlet.action=%2Flogin%2Flogin&_com_liferay_login_web_portlet_LoginPortlet_mvcRenderCommandName=%2Flogin%2Flogin&p_p_lifecycle=0

That page has a username and password form, but its like there are no css styles. When I go back to the home page there is no sign of being logged in, i.e. no admin menu and no toolbar.

When I look in the liferay log file I see: 13:52:11,156 WARN [ajp-apr-8009-exec-8][SecurityPortletContainerWrapper:341] User 0 is not allowed to access URL http://connect-np.dev.umich.edu/web/guest/home and portlet com_liferay_login_web_portlet_LoginPortlet

I first ran into the issue when I was trying to do a bundle install, but I gave up on that and am using the bitnami stack for liferay (which worked for me a couple weeks ago). I posted on liferay community, web.liferay.com/community/forums/-/message_boards/view_message/91792751
but at this point I have compared my failing bitnami stack to my working bitnami stack, only noticeable difference (since they are both so new, is the size of the vm virtual hard drive, 10Gb on working instance, 40Gb on non working instance).

  • Steps to reproduce the issue (if relevant):
    Launch an instance in US-West Oregon using the AWS marketplace latest version of liferay Liferay CE 7.0.2-1-r28 on Ubuntu 14.04.3 using 40Gb vhd
    Go to the liferay homepage on your new instance and try to sign into liferay using the default admin credentials
    see instead a weird non-styled login page and liferay log entry warning about user 0 not being allowed to access the homepage

  • Copy the apache log (if relevant):

No errors

So it turns out, many vms later that it seemed to do with how I was first accessing the instance in my browser, I had already setup the dns record and being using the domain name, once I tried to access the site using the server’s ip address it let me login successfully. Wish I had stumbled upon this days ago.

Hi,

Thanks for the detailed explanation.
We are glad that you were able to fix the issue. If you have any other questions, please do not hesitate to let us know.

Best regards,
Carlos R. Hernández