Liferay default page

Hi, I have installed bitnami-liferay-6.0.6-0-linux-ubuntu-10.04-ebs AMI on AWS (Amazon Web Service). I can access URL using http://www.xyz.com/liferay/web/guest. How can I access my URL as http://www.xyz.com

Regards Avinash

You can rename the installdir/apache-tomcat/webapps/liferay folder to "ROOT". Then change the following property in the portal-ext.properties file:

portal.ctx=/liferay -> portal.ctx=/

Once you restart the servers, you will have the Liferay main page in your domain, whithout the "liferay" string in the URL. I hope it helps.

Hi,

It works. Thanx.

One thing I did not understand why it was not working previously when I had done the same changes.

previously I had done .. 1. stop using ./ctlscript stop tomcat 2. Origional ROOT renamed. 3. ln -s /opt/bitnami/apache-tomcat/webapps/liferay ROOT 4. portal.ctx=/liferay -> portal.ctx=/ 5. start using ./ctlscript start tomcat Did not work...

This time only change is in 3rd step where I used (mv command in place of ln -s) mv liferay ROOT Rest steps as it is.. Now it is working..

Regards Avinash

If you want to use a symlink, you should enable it in the Tomcat configuration with "allowLinking" option. Take a look at http://tomcat.apache.org/tomcat-6.0-doc/config/context.html#Standard_Implementation

Hi @beltran ! I changed my default page by following those steps, and it works.
But some links and icons get broken because they still point to /liferay/icon_path. It looks like the docbase remains as /liferay instead of /.
I think it has to do with the second step of your reply to this question: http://bitnami.com/forums/forums/liferay/topics/change-port-and-url but in my installation I don’t have a META-INF directory under my apache-tomcat/webapps/ROOT/ folder. In fact, I don’t see any context.xml file at all under my entire /opt/bitnami/ directory.

I’m working on an EC2 Cloud Image

Could you help me?
Thanks in advance!

Damian

Hi,

This only happens in the Liferay welcome widget. This is a known issue that we reported to Liferay developers. As this is only a welcome message, you can remove this message from the admin panel and start using Liferay. We will document it, thanks for reporting it.

i just realized about that…
Thank you very much.

1 Like

Since some time went by and newer Versions have been released I noticed that this is not anymore sufficient to remove the /liferay in the domain. But you can still remove it by doing an additional change in the files.

in Terminal type:

$ sudo nano /opt/bitnami/apps/liferay/conf/httpd-app.conf

remove in the first Location tag the word liferay . Keep the slash. remove inside the tag the word liferay once again
Move to end of the file and remove liferay from the end of RedirectMath ^/$ /

press Ctrl + O and press enter
press Ctrl + X

restart all servers with

$ sudo /opt/bitnami/ctlscript.sh restart