Liferay 7.0.5 Warning ajp-nio-8009-exec-3

Keywords: Liferay - Amazon Web Services - Technical issue - Other
bnsupport ID: 6d99ebe6-66c2-5f47-b800-55aa7ce73a78
Description:
When I use Safari for Mac, I get the following configuration bug.
I have looked at Liferay’s forum and it points to a configuration error.

This doesn’t occur when using Google Chrome.

I am using the latest Bitnami Liferay 7.0.5 (GA6) stack on a default M3 EC2 AWS instance.

Without making any changes to a clean install on the Bitnami configured AWS instance, I get the following error when trying to adding Basic Web Content.

In the Browser:
Server timeout waiting for the HTTP request from the client

From Catalina.out:

2018-05-14 08:42:21.059 WARN  [ajp-nio-8009-exec-3][SecurityPortletContainerWrapper:363] User 33587 is not allowed to access URL http://[my.ip.address]group/test/~/control_panel/manage and portlet com_liferay_journal_web_portlet_JournalPortlet

Reproduce this error by …
Admin panel > Content > Web Content
Click the Plus + button and trying saving a Basic Web Content.

The content never gets saved.

Any help is much appreciated.

Thanks, Nick

Hi @n_burton,

I have not been able to reproduce it using Safari 11.1. Does it happen with any kind of content (e.g. a blog post, a basic document, etc.). Can you point to the Liferay’s forum entry describing the configuration error?

Thanks!

Andres R.

Hi @andresrc,

I am using Safari Version 11.1 (11605.1.33.1.4)

If you go into the admin panel > Content > Web Content

Then try to add Basic Web Content and then save it.

It does’t work for me. I’ve tried it on two freshly launched instances.

When I looked on Liferay’s forum, a guy there said, that such ([ajp-nio-8009-exec-3]) errors normally point to a configuration error.

I will try and search and find it again.

Thanks Nick.

Hi @n_burton,

I’ve finally been able to reproduce it. I’m forwarding the information to the appropriate team and they will update the ticket as soon as find any relevant information.

Regards,

Andres R.

Thank you. Will they instruct me from here?

I don’t know if this Catalina.out warning is related, but a cookie problem may be what is causing the earlier warning and problem.

This is a Warning that I am getting now …

2018-05-16 08:44:35.458 WARN  [ajp-nio-8009-exec-3][ResponseProcessCookies:185] Invalid cookie header: "Set-Cookie: vi_www_hp=z00; path=/; domain=.nytimes.com; expires=Wed, 01 Jan 2020 00:00:00 GMT". Invalid 'expires' attribute: Wed, 01 Jan 2020 00:00:00 GMT

I have no idea where the .nytimes.com domain is coming from.

Regards

Nick

Hi @n_burton

I was unable to reproduce it. I could create a Basic Web Content with Safari 11.0.3 and LifeRay 7.0.5-0, see the screenshots below:

image

What AWS machine size did you choose to create your LifeRay site? Was it a M3 EC2, wasn’it? I took a look to the files you shares via “bnsupport ID: 6d99ebe6-66c2-5f47-b800-55aa7ce73a78” and I found some errors like the one below on catalina.out:

FrameworkEvent ERROR
com.liferay.portal.kernel.exception.SystemException: com.liferay.portal.kernel.dao.orm.ORMException: org.hibernate.exception.JDBCConnectionException: could not execute query

It seems your app had problems to access the database and it could be related with memory issues. I found other kind of memory issues when using M3 type. Could you try using a T2 Large to see if the problem disappears? I know it’s a big instance but Liferay is an app with consumes a lot of RAM.

Best Regards,

Juan Ariza

Hi @jariza

I tried it the first time with my own preferred T2 Large instance and got the reported problem.

I then decided to use the “VENDOR RECOMMENDED” M3 Large instance type. I also got the same problem.

All I am doing is launching the stack from within AWS.

I have just tried again, using a T2 LARGE, and got the same problem. I am not changing or doing anything!

Here is my submitted ticket …

aeee8cc2-76e4-7c9b-685e-7db7386d06c1

I have done nothing, other than launch the instance and try to save web content.

image

The only difference that I can see between us, is that my Safari browser is up to date v.11.1

Thanks in advance.

Hi @n_burton

I can find the error on your logs now:

2018-05-21 08:55:17.433 WARN  [ajp-nio-8009-exec-9][SecurityPortletContainerWrapper:363] User 20155 is not allowed to access URL http://34.244.142.99/group/guest/~/control_panel/manage and portlet com_liferay_journal_web_portlet_JournalPortlet

I just found this StackOverFlow issue:

https://stackoverflow.com/questions/49111561/user-xxx-is-not-allowed-to-access-url

It looks like there are other issues are experiencing exactly the same issue. That issue pointed me to:

https://web.liferay.com/community/forums/-/message_boards/message/92226678

See Michau Deng response:

Initially we fixed it by giving guest users the option to manually extend their session, but our developers in Europe found that this was very confusing (see LPS-47190), because no other site does this. As a result, the final fix was to always auto-extend the session for guest users.

So if we’re auto-extending the session for guest users, why does it not work?

It’s because session.timeout.auto.extend.offset is equivalent to, “In the cases where you need to auto-extend the session, do so X seconds before you believe the session is set to expire.” Because it’s 0, it waits until the last possible second, and then attempts to extend the session. 99 times out of 100, this is probably way too late, and so session auto-extend fails.

For session auto-extend, it used to be the case that people would simply set session.timeout to something lower than the actual session length, but now we have that other property so that the session.timeout property can reflect the actual value in web.xml and we have another property to control just how much you want to live on the edge.

Could you try modifying the session.timeout property? You can do it by editing the configuration file /opt/bitnami/apache-tomcat/webapps/ROOT/WEB-INF/classes/portal-ext.properties. Then, you’d need to restart Tomcat by running:

sudo /opt/bitnami/ctlscript.sh restart tomcat

Best Regards,

Juan Ariza


Was my answer helpful? Click on :heart:

Hi @jariza

Thanks for that. NOT WORKED!

I have added the following to the /opt/bitnami/apache-tomcat/webapps/ROOT/WEB-INF/classes/portal-ext.properties

Did I do this correctly?

I am still getting the same problem and error message.

The issue is present even if I log in and try to save a Web Content straight away.

Thanks again.

Nick

Hi @n_burton,

I tried to reproduce with several t2.large instances and it was impossible, I was able to create the web content in all the cases. Everything points to a session timeout during that request and that is not related to the Bitnami configuration of the application. It could be also related to the connection speed.

I would suggest to post more details in the Liferay forums. It looks like a pretty popular issue and there are several posts that shows how to auto-extend the session. E.g https://web.liferay.com/community/forums/-/message_boards/message/3390787

Okay.

Thanks @beltran1

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.