Liferay 6.1 GA2 Bitnami Stack files not loaded

Hi folks! On a standard Liferay Installation you place the file one folder above the tomcat folder. In this file, you overwrite the default settings from ROOT/WEB-INF/classes/ However, if I place the file in the folder: /opt/bitnami/apps/liferay/data where the file resides (which is on a standard installation the same directory where you place it will not get loaded. I really have a Problem whith editing the file in ROOT/WEB-INF/classes/ as if you work with EXT-PLugins, and you need to redeploy it, you have to delete the ROOT folder, and extract it from the bundle agaiun, to get the initial state of the Portal. This would also overwrite along with all modifications made there. Any help would be really appreciated. Thanks a lot Jan

Ok. I put the entries I previously had in the file in and this seems to work.

Even though any kind of information on this topic would have been nice ;)

So long

Thanks for sharing your solution. We ship Liferay already deployed so we can use the in the WEB-INF/classes folder. This is the standard way, if you want to customize these settings you can add in the file as you mention.

Well, here are some more thoughts why the way you are shipping your custom file in the ROOT folder is NOT a good idea. If you deploy an EXT plugin, which modifies the Portal Source itself, and you ship with it, the file will get overridden and all the customization you have done are lost. If you redeploy an Ext Plugin you will have to delete the whole ROOT Folder and start with a fresh install. This will result in the loss of the file as well. You would have to have the foresight, to backup the ROOT folder of your installation. To be honest: I didnt and started swearing. Wouldn't it be better, if you leave the property files at the location and include the include-and-overwrite directive in there? Just a few thoughts. No offence intended ;)

And another Thing: in your is the directive: resource.repositories.root=/opt/bitnami/apps/liferay/data which leads to the following: the directory for the document_library would be: /opt/bitnami/apps/liferay/data/data I think this is a slight mistake there ;)

Thanks for your further thoughts and explanations. We will take a look at the current approach and try to find a better implementation to make easier the upgrade process.

Hi, I totally agree with GevatterJan, This is an old thread but it seems nothing has changed. I’m using a bitnami image with liferay-6.2.5-1. Am I wrong?

I found a solution by myself, inserting in the following:


where “” is my own file in /opt/bitnami/apps/liferay/data/

Note: I use liferay-6.2.5-1


Thanks @vincenzo_cerbone for your fix :slight_smile:

Best regards,

Javier J. Salmerón