Letsencrypt Renewal Issue

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Secure Connections (SSL/HTTPS)

bndiagnostic ID: c78f148f-6c02-81d4-bcef-188b00804296

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/

bndiagnostic failure reason: The tool could not find any issue

Description:
Let’s Encrypt is not automatically renewing. My certificate is expiring in a week, I attempted to set up the certificate manually using /opt/bitnami/bncert-tool but it is not installing a new certificate.

An error occurred when applying configurations.

The web server configuration was left unchanged. There was an error in the new
configuration, so it was reverted.

The script outputs:

Failed steps:

  • Running Let’s Encrypt: Error renewing certificates

The log shows I received a “child process exited abnormally” error but I really can not make heads or tails of the output.

Thank you for your help :slight_smile:

Hi @maui_mark,

Could you try to execute the lego command that renews your certificate? You can find the command in the crontab:

sudo crontab -l

Best regards,
Michiel

Thanks Michael -

The error thrown lead me to a solution which allowed renewal I had set up the www. subdomain record as a CNAME in DNS and Let’s Encrypt was now rejecting that (it accepted it previously) and wanted it to be an ALIAS. When I changed my DNS to ALIAS that it worked.

This is the way DNS was set when I used Let’s Encrypt originally, and it worked just fine; I also have another Bitnami stack (Wordpress stack, not just LAMP like this one) on a different domain using CNAME which I believe may be renewing properly.

Also to note (on both servers) the root crontab is empty. The lego is in the bitnami user crontab.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.