Let's Encrypt error: Table ‘DATABASE.wp_options’ doesn’t exist

Keywords: WordPress Multisite - AWS - Technical issue - Secure Connections (SSL/HTTPS)
bnsupport ID: fd737064-d595-bd20-1d0f-ae120a96d264
Description:
I’m trying to use Let’s Encrypt for Wordpress multisite. When I do so, I get an error saying that Table ‘AAA.wp_options’ doesn’t exist:

UPDATE wp_options SET option_value=‘http://URL.ca/wordpress’ WHERE option_name=‘siteurl’ OR option_name=‘home’;
ERROR 1146 (42S02) at line 1: Table ‘DATABASE.wp_options’ doesn’t exist

The table wp_options does not exist. The options are stored in DATABASE_SITEPREFIX.options for each site. But it isn’t clear to me why Let’s Encrypt is trying to change the siteurl to http://URL.ca/wordpress. My siteurl is currently https://URL.ca and I don’t think it should be changed, so I think I can just ignore this error but wanted to be sure and report the issue. The certificates are working fine.

Hi @larssandergreen,

Let’s Encrypt does not change the URL or the database, but there is an error in the Apache log related to the WordFence plugin. Could you try disabling it?

wp plugin deactivate wordfence

And restart Apache:

sudo /opt/bitnami/ctlscript.sh restart apache

Regards,
Michiel

Thanks @michiel,
I disabled Wordfence and tried again, but am still getting the same error about updating the wp_options table. It does seem weird that Let’s Encrypt is trying to do that, but it is definitely being recorded in the log that Let’s Encrypt generates.

Here is the error, which is recorded after a script called sderr being called by bncert:

Problem running post-install step. Installation may not complete correctly
Error running /opt/bitnami/mysql/bin/mysql --user=bn_wordpress --host=localhost --socket="/opt/bitnami/mysql/tmp/mysql.sock" --database=wildsigh_wpmultisite2016 -p**** <<"$
UPDATE wp_options SET option_value=‘http://wildsight.ca/wordpress’ WHERE option_name=‘siteurl’ OR option_name=‘home’;
EOF: mysql.bin: [Warning] Using a password on the command line interface can be insecure.
ERROR 1146 (42S02) at line 1: Table ‘wildsigh_wpmultisite2016.wp_options’ doesn’t exist

Script stderr:
child process exited abnormally

Error running /opt/bitnami/apps/wordpress/bnconfig.disabled --machine_hostname wildsight.ca: child process exited abnormally

I created an updated support ID, just in case: 9b595d60-c80d-b836-76c1-68f46b29d5c6

Hi @larssandergreen,

My apologies for the misunderstanding. The changes in the database are performed by the bncert tool. I was not aware you were using it. Regarding this issue, did you configure the WordPress domain as described in this guide:

https://docs.bitnami.com/ibm/apps/wordpress-multisite/configuration/configure-wordpress-multisite/

Regards,
Michiel

Hi @michiel,

Sorry, I should have been more specific.

Looking in my database, I simply don’t have a table called wp_options for my Wordpress multisite. I have wp_wild_options and wp_wild_2_options. I’m guessing that means I can’t use the bncert tool (or need to ignore those errors). Using bnconfig has the same problem, as wp_options doesn’t exist.

Hi @larssandergreen,

It seems the prefix of the WP tables is not the default one. The bncert tool expects it to be “wp_”. You can change it in the bnsupport/apps/wordpress/htdocs/wp-config.php file:

Modifying this string:

$table_prefix = 'wp_';

And change the existing tables with phpMyAdmin:

https://www.bettertechtips.com/wordpress/change-wordpress-table-prefix/

Another option is to issue the certificate manually:

https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/#alternative-approach

Regards,
Michiel

Thanks @michiel,

I’m not quite clear on what you are recommending. My table prefix in wp-config is correct. Are you saying that I should rename all my database tables to remove the current table prefix in order to use the bncert tool?

Currently, the certificates are being issues correctly, but the tool is telling me it may not have been able to set up automatic renewals correctly. I don’t care if the tool gives me an error trying to change the siteurl, but I do care about the automatic renewals.

Hi @larssandergreen,

The bncert tool is trying to configure the hostname and it’s expecting the table prefix to be wp_. In order to use it you would need to change the prefix, but my suggestion is to issue a certificate manually instead.

Regards,
Michiel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.