LDAPS not connecting "Unable to connect"

Keywords: Redmine - Virtual Machines - Technical issue - Application configuration

bnsupport ID: 75318f6b-dfb5-ff68-ae78-25127708e3e4

bndiagnostic output:

? Connectivity: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
Error seen in Redmine:
“Unable to connect (Connection reset by peer - SSL_connect)”

Error seen in Windows Server 2012 R2 event viewer:
“An TLS 1.2 connection request was received from a remote client application, but none of the cipher suites supported by the client application are supported by the server. The SSL connection request has failed.”

LDAP (with no SSL) on port 389 works.

This error started happening after I moved from a Bitnami virtual machine with Redmine 3.3 to Redmine 4.2. With Redmine 3.3 I had it working using LDAPS.

Thoughts on what I may be missing to get this working?

Hello @adamv,

We don’t see any red flag in your configuration nor should there be any issue related to the stack configuration. For information regarding the application itself or customization of the content within the application, we highly recommend checking forums and user guides made available by the project behind the application.

https://www.redmine.org/projects/redmine/boards

Don’t hesitate to come back if you think the issue may indeed be related to Bitnami configuration.

Regards,
Francisco de Paz