LAMP-stack, imagick and webp

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Application configuration

bnsupport ID: 7db6352c-94fe-d040-35e7-45d75e1f7a66

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
Hi,

Since GD in the lamp-stack doesnt support imagick, i have been trying to install imagick along with imagemagick to enable webp support on the server.

I have tried following these posts:


Following those, im able to install the imagick and imagemagick, and when running the command convert --version i can see imagemagick has webp enabled.

I can complete alle the installations, but when i look at the phpinfo() i can see that imagick is beeing loaded, but is says that there are 0 supported imagemagick formats.

Im runng your PHP7.4 stack. Is there something im missing?

Additional, im running the LAMP stack on AWS Lightsail.

I have also tested just enabling imagick in the php.ini file with same result. Is says that imagick and imagemagic is activated, but with no supported formats

Solved by following this solution:

Hello @meldgaard,

Thanks for using our Bitnami stacks! I’m glad you were able to solve the issue and kudos for sharing with the community how you were able to solve it.

I’ll be closing the thread as it is now marked as solved. Please do not doubt to open a new ticket if you encounter any other issues

Regards,
Francisco de Paz