Lamp does not work ldap

Keywords: LAMP/MAMP/WAMP - Linux - Technical issue - Other
Description:
Hello, good afternoon, I have the lamp installed on a computer with Ubuntu 20 and installed the glpi but when synchronizing with LDPA it generates the following window The LDAP extension of your PHP interpreter is not installed or It is impossible to use LDAP as an external connection source

Hi @fritzjacobg,

Can you check if ldap appears in the output of the following command:

php -m 

Regards,
Michiel

[PHP Modules]
calendar
Core
ctype
date
exif
FFI
fileinfo
filter
ftp
gettext
hash
iconv
json
libxml
openssl
pcntl
pcre
PDO
Phar
posix
readline
Reflection
session
shmop
sockets
sodium
SPL
standard
sysvmsg
sysvsem
sysvshm
tokenizer
Zend OPcache
zlib

[Zend Modules]
Zend OPcache

Se encontraron errores al procesar:
mysql-server-8.0
mysql-server
E: Sub-process /usr/bin/dpkg returned an error code (1)

Hello @fritzjacobg,

I have just checked that latest versions of LAMP include ldap (e.g. 7.4.16-5).

$ php -m | grep ldap
ldap

Could you try this version?

Let me explain a bit, I don’t know if it is affecting me, I have Ubuntu 20 installed and the lamp version 7.4.10 installed, but in the lamp where I attach the glpi it is on port 8080 because it cannot make port 80 work, it tells me that it is busy and I I imagine the ubuntu has it running that port

Hello @fritzjacobg,

As you say, probably your port 80 is blocked.

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.