Joomla! Module on LAMP

Keywords: LAMP/MAMP/WAMP - Google Cloud Platform - Technical issue - Other
Description:
Hi
I used to install the module with no problem quickly.
This time failed.

Look please LAMP version: 7.4.16-5-r01. Something is going wrong
The installation process failed because of properties.ini which was incomplete. I replaced it.
The next issue reads:

Warning: Problem running post-install step. Installation may not complete correctly Error running /opt/bitnami/ctlscript.sh start @@BITROCK_MYSQL_FLAVOUR@@ > /dev/null 2>&1: child process exited abnormally.

Not clear what way to manage multi websites if no bitnami-apps-vhosts.conf and bitnami-apps-prefix.conf

Thank you in advance

Hi @larissa111

Thanks for using Bitnami LAMP!

We have recently stopped support for Bitnami LAMP modules. The stack does allow to deploy PHP applications, but we do no longer provide those modules (unlike we do for XAMPP).

Instead, you can either launch a ready-to-use Bitnami Joomla instance or deploy Joomla yourself in your server by following this guide:
https://docs.bitnami.com/google/infrastructure/lamp/administration/deploy-php-application/

Alternatively, you can also install the whole Joomla stack (Apache, DB, PHP & Joomla) using one of our installers:
https://bitnami.com/stack/joomla/installer

Regarding the error you mention, it seems that the DB is having trouble to start.

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

Best regards,
Jose Antonio Carmona


Was my answer helpful? Click on :heart:

1 Like

Thanks for a quick reply

It is clear now.

Have a good day

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.