Jodconverter and open in office confoguration doesnt seem to work

hi,

i launched exo platform in google platform trough bitnami and also i had a local copy on my laptop running ubuntu for testing purposes before trying it out on the servers on cloud.

now i have set the configuration on jodconverter and the open in office on my laptop and i was delighted that the configuration worked now convinced of the result i tried it on the google servers but the configuration doesn’t seem to have an effect i even tried restarting the server in hopes of seeing the result but to no avail.

my question is the configuration is found on the home folder of the user now i checked on the tomcat folder the configuration is the same it reflects what i did on the configuration file found on home/user/apps/exoplatform/gatein/conf/exo.properties

am i missing something

here is a part of the exo.propertues
exo.jodconverter.enable=true
exo.jodconverter.portnumbers=2002,2003,2004,2005
exo.jodconverter.officehome=/opt/libreoffice5.0
exo.jodconverter.taskqueuetimeout=30000
exo.jodconverter.taskexecutiontimeout=120000
exo.jodconverter.maxtasksperprocess=200

thank you

Hi @angelogasa,

Have installed libreoffice in your google cloud instance? right now you are pointing the office home to /opt/libreoffice5.0 but we do not install it by default.

To get it working you would need to install it manually and set the path properly to the libre office installation directory.

Hope it helps. Let me know if you need any help.

Edu.

i am sorry forgot to mention i did install openoffice and even tried libreoffice but it didnt work

i installed libreoffice and openoffice but tried one at a time still wont work

Hi @angelogasa,

Did you set the path to your openoffice/libreoffice installation properly? You should set it at:

exo.jodconverter.officehome=/opt/libreoffice5.0

Edu.

yes i did set the path i read the log files and i saw a warning about officemanager if i remember it right

Hi @angelogasa,

We could configure Libreoffice over eXo following the next guide:

http://docs.exoplatform.com/public/index.jsp?topic=%2FPLF40%2FPLFAdminGuide.Configuration.JODConverter.html

Would you mind sending us the log files with the jodconverter error you get? You can send us the exo log that is on /home/user/apps/exoplatform/logs/platform.log and the tomcat log on /home/user/tomcat/logs/catalina*.

Also you can take a look at the following post, maybe it helps:

https://community.exoplatform.com/portal/intranet/forum/topic/topic6efc26120a2106c63a4ec233116baf04

Regards,
Fernando

Hi,
Am using Bitnami eXo Platform 4.3
Have the same issue - cannot view office documents.
Have Installed Libreoffice but still can’t view.

how to upload the log files here?

Hi @qtech_labuan,

Could you indicate which steps you made to configure LibreOffice over eXo? Did you read the guide or the post @fer indicated above?

To upload the log file, you can try pasting the relevant error in code blocks, using the following format:

```
your code here
```

Thanks!

Hi Marcos,
From the platform.log :-1
,
2016-05-10 01:51:15,200 | INFO | File ‘/Groups/spaces/myaid/Documents/marketing-plan-from-cargo/CANGO IDEAS.pptx’ is too big for preview. [o.e.services.pdfviewer.PDFViewerService]
2016-05-10 01:51:32,390 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:49,352 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:49,370 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:49,385 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:49,400 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:49,456 | INFO | File ‘/Groups/spaces/myaid/Documents/draft/MYAID DRAFT.pptx’ is too big for preview. [o.e.services.pdfviewer.PDFViewerService]
2016-05-10 01:51:49,640 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:49,774 | INFO | File ‘/Groups/spaces/myaid/Documents/draft/MyAid proposed marketing.pptx’ is too big for preview. [o.e.services.pdfviewer.PDFViewerService]
2016-05-10 01:51:49,807 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:49,869 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:54,105 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:54,356 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:54,660 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl]
2016-05-10 01:51:54,662 | WARN | Can not preview the document having path : Groups/spaces/myaid/Documents/draft/Ambulance+service+projection.xlsx [org.exoplatform.ecm.webui.utils.Utils]
,

I’m a novice. I got no idea what this means. TQ for your guidance.

Hi,

In your log there are a few strange errors:

2016-05-10 01:51:15,200 | INFO | File '/Groups/spaces/myaid/Documents/marketing-plan-from-cargo/CANGO IDEAS.pptx' is too big for preview. [o.e.services.pdfviewer.PDFViewerService] 
2016-05-10 01:51:49,456 | INFO | File '/Groups/spaces/myaid/Documents/draft/MYAID DRAFT.pptx' is too big for preview. [o.e.services.pdfviewer.PDFViewerService] 
2016-05-10 01:51:49,774 | INFO | File '/Groups/spaces/myaid/Documents/draft/MyAid proposed marketing.pptx' is too big for preview. [o.e.services.pdfviewer.PDFViewerService] 

Could you check if the document sizes are very big? Could you try to check with an empty document, which will be as small as possible?

Also, there is this error:

2016-05-10 01:51:54,660 | WARN | this OfficeManager is currently stopped! [o.e.s.c.j.impl.JodConverterServiceImpl] 

It seems that your LibreOffice is not currently started. Could you try to start it manually, restart the Tomcat server and check if it works?:

INSTALLDIR/libreoffice/program/soffice.bin --nofirststartwizard --nologo --headless --accept=socket,host=localhost,port=8100\;urp\;StarOffice.ServiceManager

Regards

Hi Marcos,

I share the same admin responsibility with qtech_labuan on the same exo server. I try your advice on manually start libreoffice and this is what shown to me.

taidaniel_my@ukgs-exo:sudo /opt/bitnami/libreoffice/program/soffice.bin --nofirststartwizard --nologo --headless --accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager
/opt/bitnami/libreoffice/program/.soffice.bin: error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

Hello @alexsuiming_tay,

Could you please try with the next command?

INSTALLDIR/libreoffice/program/soffice --nofirststartwizard --nologo --headless --accept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager

I hope it helps,

Regards,
Andres Gonzalez

Hi,
I’ve tried what you mentioned & this is what I get :-

sudo INSTALLDIR/libreoffice/program/soffice --nofirststartwizard --nologo --headless --acc
ept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager
sudo: INSTALLDIR/libreoffice/program/soffice: command not found

Thanks

Hello @qtech_labuan

Please note that you have to replace “INSTALLDIR” with the path to the directory where you installed your Stack.

For example, if your Stack is installed under /user/home/, the right command would be:

sudo /user/home/libreoffice/program/soffice --nofirststartwizard --nologo --headless --accept=socket,host=localhost,port=8100\;urp\;StarOffice.ServiceManager

Best Regards,

Juan

Hi,
I’ve tried that and this is the result.

taidaniel_my@ukgs-exo:~$ sudo find / -name ‘soffice.bin’
/opt/bitnami/libreoffice/program/soffice.bin
taidaniel_my@ukgs-exo:~$ sudo /opt/bitnami/libreoffice/program/soffice --nofirststartwizard --nologo --headless --a
ccept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager
/opt/bitnami/libreoffice/program/.soffice.bin: error while loading shared libraries: libGL.so.1: cannot open shared
object file: No such file or directory

Regards

Hi,

I googled around and did this and installed “libglu1”. After installing, I’m able to execute libreoffice with the command you instructed.

“taidaniel_my@ukgs-exo:~$ sudo /opt/bitnami/libreoffice/program/soffice --nofirststartwizard --nologo --headless --a
ccept=socket,host=localhost,port=8100;urp;StarOffice.ServiceManager”

But after executing, it just pause there. It doesn’t come back to the prompt. I’ve check the running processes and see that libreoffice is running. After stopping & starting eXo, I still can’t view office documents.

Regards

Hi,
Looking at platform.log, I see this :-

“2016-07-05 05:05:09,713 | WARN | Wrong configuration ==> Use default officeHome value of DefaultOfficeManagerConfiguration [o.e.s.c.j.impl.JodConverterServiceImpl]”

My exo.properties seetings:-

exo.jodconverter.enable=true
exo.jodconverter.portnumbers=2002
exo.jodconverter.taskqueuetimeout=30000
exo.jodconverter.taskexecutiontimeout=120000
exo.jodconverter.maxtasksperprocess=200
exo.jodconverter.retrytimeout=120000
exo.jodconverter.officehome=/opt/bitnami/libreoffice/program

What could be causing this?

Hi @qtech_labuan,

Looking at platform.log, I see this :-

“2016-07-05 05:05:09,713 | WARN | Wrong configuration ==> Use default officeHome value of DefaultOfficeManagerConfiguration [o.e.s.c.j.impl.JodConverterServiceImpl]”

That is just a warning and should not not have any effect.

Apart from that, we have been able to reproduce a library issue in a Google Cloud Engine instance:

/opt/bitnami/libreoffice/program/oosplash: error while loading shared libraries: libXinerama.so.1: cannot open shared object file: No such file or directory

We will check why this is happening, but in the meantime, it will be enough to execute this in your instance to get passed it:

sudo apt-get install libxinerama-dev

Please note that you must not execute soffice.bin but soffice, since it is a wrapper and it loads all of the required libraries (except the one I mentioned above):

sudo /opt/bitnami/libreoffice/program/soffice --nofirststartwizard --nologo --headless --accept=socket,host=localhost,port=8100\;urp\;StarOffice.ServiceManager

An alternative is to use the CTL script:

sudo /opt/bitnami/libreoffice/scripts/libreoffice_ctl.sh start

Once that is done, LibreOffice should be working but in our case we found that it is not starting properly, it ends up being a zombie process (defunct):

$ ps aux | grep soffice
...
root     102753  0.0  0.0      0     0 pts/6    Z+   17:03   0:00 [.soffice.bin] <defunct>
...

The main issue is that LibreOffice is not starting properly, so once you get it started, you will only have to restart eXo Platform (sudo /opt/bitnami/ctlscript.sh restart tomcat).
We are still investigating why this is happening and we will let you know of any progress on this.

Best regards,
Marcos

Hi,
Thanks. I’ve tried what you mentioned & I get the same results. soffice end up defunct.

Looking forward to your suggestions.

Regards