Job for bitnami.service failed because the control process exited with error code. See "systemctl status bitnami.sr

Keywords: WordPress + NGINX + SSL - AWS - Technical issue - Permissions

bnsupport ID: 5e09d6b2-aef8-914e-85e6-d9718cd5c3f8

bndiagnostic output:

? Apache: Found possible issues
? Connectivity: Found possible issues
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: A documentação não fez nenhuma mudança significativa

Description:
I was trying to install an SSL certificate on my instance on AWS, following their tutorial, when running the sudo /opt/bitnami/ctlscript.sh start command I get the following error:
Job for bitnami.service failed because the control process exited with error code.
See "systemctl status bitnami.service

Hi @raphaelmourateixeira,

Did you follow the steps from this guide?

https://docs.bitnami.com/bch/how-to/generate-install-lets-encrypt-ssl/#alternative-approach

Regards,
Michiel

Yes, I already tried! But this solution doesn’t work for me! The error mentioned above appears after executing the command “sudo /opt/bitnami/ctlscript.sh start”! This is causing a big problem on my server

Hi @raphaelmourateixeira,

The server.crt and server.key symlinks that point to your cert and key are in the /opt/bitnami/apache/conf folder while in the Apache configuration “apache2/conf/bitnami/bitnami-ssl.conf” you have set the following:

  SSLCertificateFile "/opt/bitnami/apache/conf/bitnami/certs/server.crt"

You need to either move the certificate symlinks to “”/opt/bitnami/apache/conf/bitnami/certs/" or update the SSLCertificateFile and SSLCertificateKeyFile in the “apache2/conf/bitnami/bitnami-ssl.conf” file.

Regards,
Michiel

Hi, thanks so much for the reply, but how can I do this? Can you guide me with the commands?

hello, do you have any answers?

Hi @raphaelmourateixeira,

You can open “/opt/bitnami/apache2/conf/bitnami/bitnami-ssl.conf” using an inline editor like nano:

sudo nano /opt/bitnami/apache2/conf/bitnami/bitnami-ssl.conf

And then change the path after “SSLCertificateFile” and “SSLCertificateKeyFile” to “/opt/bitnami/apache/conf/server.crt” and “/opt/bitnami/apache/conf/server.key” respectively.

And then save and restart Apache:

sudo /opt/bitnami/ctlscript.sh restart apache

Regards,
Michiel

1 Like

After performing these actions, when starting or apache I received or : Failed to restart apache

Hi @raphaelmourateixeira,

Can you run:

  apachectl -t -f /opt/bitnami/apache2/logs/error_log

And tell me the output?

Can you also run the bndiagnostic tool again?

Regards.
Michiel

AH00534: httpd: Configuration error: No MPM loaded.

More: sudo apachectl -S
AH00526: Syntax error on line 4 of /opt/bitnami/apache/conf/vhosts/wordpress-https-vhost.conf:
SSLCertificateFile: file ‘/opt/bitnami/apache/conf/bitnami/certs/server.crt’ does not exist or is empty.

even performing the changes I get this message

Hi @raphaelmourateixeira,

  • Can you check the value of SSLCertificateFile in “/opt/bitnami/apache/conf/vhosts/wordpress-https-vhost.conf”? Does it point to the correct path of server.crt?

  • Can you check the “/opt/bitnami/apache/conf/server.crt" file?

    ls -la /opt/bitnami/apache/conf/server.crt

Could you run the bndiagnostic tool again?

Regards,
Michiel

SSLEngine on
SSLCertificateFile “/opt/bitnami/apache/conf/bitnami/certs/server.crt”
SSLCertificateKeyFile “/opt/bitnami/apache/conf/bitnami/certs/server.key”
DocumentRoot /opt/bitnami/wordpress
<Directory “/opt/bitnami/wordpress”>
Options -Indexes +FollowSymLinks -MultiViews
AllowOverride None
Require all granted
# BEGIN WordPress fix for plugins and themes
# Certain WordPress plugins and themes do not properly link to PHP files because of s$
# https://github.com/bitnami/bitnami-docker-wordpress-nginx/issues/43
RewriteEngine On
RewriteRule ^bitnami/wordpress(/.) $1 [L]
# END WordPress fix for plugins and themes
# BEGIN nip.io redirection
RewriteEngine On
RewriteCond %{HTTP_HOST} ^([0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3}.[0-9]{1,3})(:[0-9]{1,5$
RewriteRule ^/?(.
) %{REQUEST_SCHEME}://%1.nip.io%2/$1 [L,R=302,NE]
# END nip.io redirection
# BEGIN WordPress Multisite
# Using subdomain network type: https://wordpress.org/support/article/htaccess/#multi$
RewriteEngine On
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteBase /
RewriteRule ^index.php$ - [L]
# add a trailing slash to /wp-admin
RewriteRule ^wp-admin$ wp-admin/ [R=301,L]
RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d

For LS - LA:
lrwxrwxrwx 1 root root 57 Sep 24 19:08 /opt/bitnami/apache/conf/server.crt -> /etc/letsenc
rypt/live/imperiomarinho.com.br/fullchain.pem

Good morning, can you help me with one more thing?

Hi @raphaelmourateixeira,

Can you give more details?

Regards,
Michiel

Hi Michael, I can give you more details, but what do you need?

Hi @raphaelmourateixeira,

In your configuration file the “SSLCertificateFile” and “SSLCertificateKeyFile” are pointing to these paths respectively:

/opt/bitnami/apache/conf/bitnami/certs/server.crt
/opt/bitnami/apache/conf/bitnami/certs/server.key

While the server.crt and server.key seem to be in this folder:

/opt/bitnami/apache/conf/
/opt/bitnami/apache/conf/

As you can see this is not the same path. As I said you can either change the path in the configuration file or move the files to the other folder.

Regards,
Michiel

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.