Jenkins - Invalid login information

I’m not sure if I’m making a mistake but it seems to me like, the password configured via bitnami-base-password isn’t setup when I provision a jenkins instance into Google Cloud Platform (GCP):

gcloud compute instances create ${VM_NAME} \
--image-project bitnami-launchpad \
--image bitnami-jenkins-1-611-0-r01-linux-debian-7-x86-64 \
--zone ${ZONE} \
--machine-type ${MACHINE_TYPE} \
--metadata "bitnami-base-password=${JENKINS_PWD}" \
"bitnami-default-user=user" \
"bitnami-key=jenkins" \
"bitnami-name=Jenkins" \
"bitnami-url=//bitnami.com/stack/jenkins" \
"bitnami-description=Jenkins." \
"startup-script-url=https://dl.google.com/dl/jenkins/p2dsetup/setup-script.sh" \
--scopes "https://www.googleapis.com/auth/userinfo.email" \
"https://www.googleapis.com/auth/devstorage.full_control" \
"https://www.googleapis.com/auth/projecthosting" \
"https://www.googleapis.com/auth/appengine.admin" \
--tags "https-server" \
"bitnami-launchpad"

Always run into: Invalid login information. Please try again anyone else see what I’m messing up here?

Hello @pulkitsinghal;

I launched a Jenkins instance from Bitnami Google Launchpad and the password is fine.
The problem can be in the parameters of the command you rant.

Please, can you check bitnami-base-password inside Google Developer Console -> Your project -> VM instances -> Your Jenkins instance ?

Is the same password as you used in the command?

Regards,
Jorge

i have the same problem, and the login and password on the google developer console are exactly like in the script i used to set up the machine - still i cant log in on the web interface at the /jenkins/login url. how can i debug this further?

my password is 21 chars long. is that too long, perhaps?

i also see this in the logfile every second:

[Fatal Error] slave-agent.jnlp:1:1014: The element type "HR" must be terminated by the matching end-tag "</HR>".
Failing to obtain file:/slave-agent.jnlp
java.io.IOException: file:/slave-agent.jnlp doesn't look like a JNLP file; content type was null 
#011at hudson.remoting.Launcher.parseJnlpArguments(Launcher.java:304)
#011at hudson.remoting.Launcher.run(Launcher.java:219)
#011at hudson.remoting.Launcher.main(Launcher.java:192)
Waiting 10 seconds before retry

could this be related?

i tried to locate the error logs of the login attempts following this advice. But there are no such files in /opt/bitnami/apps/jenkins/jenkins_home (which i assume is JENKINS_HOME), or any of its subfolders.

Hi @andreas,

Could you try to reset your application password running the bnconfig command mentioned in https://wiki.bitnami.com/Amazon_cloud/Where_can_I_find_my_AWS_Marketplace_credentials%3F#How_to_reset_the_application_password.3f?

Hope it helps,
Gonzalo

After the above efforts and further reading I came to the conclusion that the password hash that gets put into the VM does not correspond to the password string. Did someone actually manage to deploy with your tool? I changed the hash in the config file from the command line and made it work. Please investigate and fix.

Hi @andreas,

I’m glad to hear that you manage to solve your problem. We’ll investigate the issue and I’ll let you know when we find something.

Jota

Thankyou,
This post help me found what is wrong.
If someone else have this issue, when tou create your VM, the metadata bitnami-base-password length must be8 or more, and contains number and letter

Hi @kammoun_o,

We are glad it solved the issue. Thanks for letting us know.

Regards.