Jenkins Application Unavailable

Keywords: Jenkins - Windows - Technical issue - Upgrade
Description:
I was working with a Jenkins installation on a server. Our company uses Qualys to scan for vulnerabilities. It noticed the version of Apache Tomcat was 8.0 so I wanted to update it to 9.0. I tried updating Apache Tomcat by downloading the core 64bit zip from the Tomcat Apache website.

I made a backup of C:\Bitnami\jenkins-2.32.1-0\apache-tomcat. I stopped the Apache, Tomcat 8 and Jenkins services. I then extracted the contents of the zip, copied those files and pasted them into C:\Bitnami\jenkins-2.32.1-0\apache-tomcat. I let it overwrite all the files it matched.

It seems Tomcat 9 is running fine when I go to http://127.0.0.1:8080 on the server. If I try to access jenkins by going to http://127.0.0.1/jenkins I get the “Your application is not available” message.

I’m not familiar with Jenkins and I inherited this server along with everything on it from another admin. Not sure what to check or where to go from here.

Hi @Uncleroy67,

The Bitnami solution uses the AJP protocol to connect the Apache and the Tomcat services, can you check the AJP port is configured in the new Tomcat you copied to the installation’s folder?

Hi jota,

Are you referring to this portion of the server.xml in the conf directory?
image

I left it as the defaults and removed the comment, restarted the services and tried connecting to Jenkins. If there’s another config setting I can check, let me know.

Hi @Uncleroy67,

Please run the Bitnami support tool so we review your configuration and log files

How to Run the Bitnami Support Tool

Please note that you need to paste the code ID that is shown at the end.

Thanks Jota.

I ran the tool, however it said it was unable to upload directly and it provided me the zip. I ensured the server was connected to the internet so I’m not sure what the issue may be. Is there another way I can upload this zip to you securely?

Hi @Uncleroy67,

I just sent you a private message with the instructions. Can you follow them and update this conversation once you do that?

Thanks

Hi Jota,

I’ve replied to the private message.

Thanks.

I just replied to your private message

Hi Jota,

Please see private message for my reply.

Hi @Uncleroy67,

I didn’t receive the information. Can you share a link to download the files directly in the private message? Don’t forget to update this public thread as well

I left a message in the private thread.

Hi @Uncleroy67,

I found that I received an email from your company that is forcing me to register in the website and I understand I could download the files later. Please note that more member of the Support team will be involved in this support ticket so that will make the support flow really hard to follow if everyone needs to register in your site to download the files.

In order to speed up this ticket, I’ll give you some instructions you can check in order to debug the issue:

  • First of all, you can try to enable the http and https connectors in the server.xml file in order to access the application using those ports (without using Apache as proxy). Does that work? If not, do you find any error message in the error logs of Tomcat (installdir/apache-tomcat/logs)?

  • If the previous step worked properly, you can now try to access Jenkins using the Apache proxy. You will need to use the port 80/443 and see if you can access the site. If that doesn’t work, is there any error in the Apache’s error log (installdir/apache2/logs/)

  • Finally, can you try to install the latest version of the Bitnami Support tool to see if that fixes the issue when uploading the files to the server?

https://downloads.bitnami.com/files/bnsupport/latest/bnsupport-windows.exe

Thanks

Hey Jota,

I tried your troubleshooting steps. See the private message for details.

Hi @Uncleroy67,

More things to check:

  • is the Jenkins’ folder inside the Tomcat’s webapps one?
  • Does the Tomcat’s log mentions the Jenkins deployment? With the lines you copied, we don’t know if the app was successfully deployed or not

Hi Jota,

This is Uncleroy67. Yes the Jenkins folder is inside the webapps directory. Full path - C:\Bitnami\jenkins-2.23.1-0\apache-tomcat\webapps. I’ve attached a copy of the log. IT appears that the application has deployed, however I am noticing a few Access Denied messages throughout the log. Perhaps this is a permissions issue?

Khomsunt (Nick) Rodpai
Enterprise IT - Windows Operations
E: khomsunt.rodpai@lmco.commailto:khomsunt.rodpai@lmco.com
P: 720.842.6147

Hi @Uncleroy67,

I quickly checked the log file and found that there are multiple errors there (Failed Loading global config, java.nio.file.AccessDeniedException: C:\Bitnami\jenkins-2.32.1-0\apps\jenkins\jenkins_home\secrets\filepath-filters.d\30-default.conf, …)

Your team will need to check those ones. Please note that we do not provide Jenkins with Tomcat 9 so we don’t know if the application supports that version. As this is not a tested scenario, we have been helping you to try to get it running again but it seems that there are a lot of things you will need to fix before accessing the app. Please try to solve them by your own (we suggest you continue using Tomcat 8.x as this is the version tested and verified by Bitnami) and reach out to us in case you have any question regarding the Bitnami configuration.

Thanks

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.