Issues customising Virtue Theme

Keywords: WordPress - Microsoft Azure - Technical issue - Application configuration

bnsupport ID: 0e532b4b-60ba-8938-f6f8-ed217ba043c9

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

Description:
I have installed the Virtue theme but am unable to customise it. I am in discussion swith the theme support and they are saying that ther might be an issue with the wordpress installation as the folder locations for th errors in the console screen are not correct.

The theme support team have advised me that the directory path seems to indicate that the installation is a WordPress inside another WordPress.

Can you please advise if you have another image that can be used to install Wordpress?

Thanks

Hello @stephen4,

Your instance only contains a WordPress installation at /opt/bitnami/wordpress, I’m not sure why they might be thinking a WordPress inside another WordPress is in place. The only difference I’m seeing from the default configuration is a .htaccess file in the Wordpress folder, which shouldn’t be configured there. You can check how to apply the configuration here:

https://docs.bitnami.com/azure/apps/wordpress/administration/use-htaccess/

Regards,
Francisco de Paz

Hello @fdepaz,

The theme support team asked me to use inspect and console to see if I was getting errors similar to this “GET http://xx.xx.xx.xx/wp-content/bitnami/wordpress/wp-content/themes/virtue/themeoptions/inc/fields/slider/vendor/nouislider/redux.jquery.nouislider.css?ver=5.0.0 net::ERR_ABORTED 404 (Not Found)”

Thanks

Hello @fdepaz,

I have just created a test WordPress installation this time using the Azure Marketplace and the WordPress App Service from WordPress and I can customise the theme, so it looks like there is an issue with the Bitnami WordPress install package.

Thanks

Hi @stephen4,

Thanks for your message. Apart from what @fdepaz mentioned, can you try to run the HTTP get action agains the next URL? Replace the IP_ADDRESS placeholder with your real value

http://IP_ADDRESS/wp-content/themes/virtue/themeoptions/inc/fields/slider/vendor/nouislider/redux.jquery.nouislider.css?ver=5.0.0

I think the /bitnami/wordpress/wp-content part of the URL you shared is wrong, that folder is a symlink (from /opt/bitnami/wordpress/wp-content to /bitnami/wordpress/wp-content) for persistence, but it shouldn’t be present in the internals WordPress URLs. Can you tell us where did you get that URL? Is it hardcoded into the plugin somehow?

Hi @gongomgra,

I have just done an inspect whilst logged into the admin screen and selected theme options then looked at the console errors again and here is 1 of the 29 errors that I get "GET http://xx.xx.xx.xx/wp-content/bitnami/wordpress/wp-content/themes/virtue/themeoptions/assets/css/vendor/jquery-ui-bootstrap/jquery-ui-1.10.0.custom.css?ver=3.6.0.2 net::ERR_ABORTED 404 (Not Found) " but don’t get any errors and can customise on a quick test site that I just created using the non-Bitnami WordPress from the Azure Marketplace.
Thanks

Hi @stephen4,

Thanks for the info. Can you contact the theme developers again and ask them for any options to update those URLs? As I mentioned, the /bitnami/wordpress/wp-content part shouldn’t be present. Maybe they are getting the absolute real path of the installation not taking into account it is a symbolic link?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.