Issue with SSL. And want to know how to do

Keywords: WordPress + NGINX + SSL - AWS - Technical issue - Secure Connections (SSL/HTTPS)

bnsupport ID: 7e7e1b22-112a-1403-ac2f-ff61ebf363ea

bndiagnostic output:

? Nginx: Found possible issues
? Mariadb: Found possible issues
? Connectivity: Found possible issues
? Resources: Found possible issues
? Processes: Found possible issues
https://docs.bitnami.com/installer/infrastructure/nginx/troubleshooting/
https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mariadb/
https://docs.bitnami.com/general/faq/administration/use-firewall/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

Description:
I am trying to use SSL and the site are down.

  1. What is my issue? related with memory?
  2. How can I use SSL? Please find below URLs (https://seoneurons.com/bitnami/ssl-certificate-bitnami-wordpress-nginx/)

Hello @origilalala,

The main issue is that NGINX service is not running. The error is:

2022/01/01 12:29:05 [emerg] 21611#21611: cannot load certificate "/opt/bitnami/letsencrypt/certificates/www.XXX.co.kr.crt": BIO_new_file() failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/opt/bitnami/letsencrypt/certificates/www.XXX.co.kr.crt','r') error:2006D080:BIO routines:BIO_new_file:no such file)

Note that www should not be there, so update your /opt/bitnami/nginx/conf/server_blocks/wordpress-https-server-block.conf file removing it. After that, start NGINX:

sudo /opt/bintami/ctlscript.sh start nginx

Regards

I removed the file and execute ‘sudo’ but still do not work.

Please check again and let me know. Need I do ‘bitnami diagnostic tool’ again?

And please let me know how to use ‘https’

Hi @origilalala,

I mentioned that www should not be in the certificate line, so you need to update the file by removing the www part from the certificate so it points to the right path.

Please share a new support tool output if you still have issues after that.

Regards

Keywords: WordPress + NGINX + SSL - AWS - Technical issue - Secure Connections (SSL/HTTPS)

bnsupport ID: 70a7f9b2-4142-0ffe-1c39-9cf883823951

bndiagnostic output:

? Nginx: Found possible issues
? Connectivity: Found possible issues
https://docs.bitnami.com/installer/infrastructure/nginx/troubleshooting/
https://docs.bitnami.com/general/faq/administration/use-firewall/

bndiagnostic failure reason: I do not know how to perform the changes explained in the documentation

Description:
I’ve done Upgrade my AWS volume but still have a problem. What’s going on?

Hi @origilalala,

I think this is the same topic:

Please avoid opening duplicated cases.

Regards

Oops, I removed the file.
Fortunately I had back it up so I will update that.

Thank you so much Davidg!

I tried what you say but stiIl have issue.

I removed ‘www f’rom ‘wordpress-https-server-block.conf’ and tried ’
sudo /opt/bitnami/ctlscript.sh start nginx’

Please let me know.

Regards

Can you access your site now? Is NGINX running?

I can’t access it. As you find my domain - pilaf.co.kr

The redirection you configured is wrong

❯ curl -LI pilaf.co.kr
HTTP/1.1 301 Moved Permanently
Server: nginx
Date: Tue, 11 Jan 2022 08:53:23 GMT
Content-Type: text/html; charset=UTF-8
Connection: keep-alive
X-Powered-By: PHP/7.4.24
Set-Cookie: uncode_privacy[consent_types]=%5B%5D; expires=Wed, 11-Jan-2023 08:53:23 GMT; Max-Age=31536000; path=/; SameSite=Strict
X-Redirect-By: WordPress
Location: https://pilaf.co.krpilaf.co.kr/
X-Frame-Options: SAMEORIGIN

curl: (6) Could not resolve host: pilaf.co.krpilaf.co.kr

Please review the redirection configuration and ensure you do not concat the domain name when performing the redirection.

Please let me know where can I, how to fix.

Hi @origilalala,

It seems there is something wrong in WordPress because it’s the application who is performing the redirection

X-Redirect-By: WordPress
Location: https://pilaf.co.krpilaf.co.kr/

I reviewed the wp-config.php file and found this

define( 'WP_HOME', 'https://pilaf.co.kr' . $_SERVER['HTTP_HOST'] . '/' );
define( 'WP_SITEURL', 'https://pilaf.co.kr' . $_SERVER['HTTP_HOST'] . '/' );

You need to substitute those lines with these ones

define( 'WP_HOME', 'https://pilaf.co.kr/');
define( 'WP_SITEURL', 'https://pilaf.co.kr/');

https://docs.bitnami.com/aws/apps/wordpress-pro/administration/configure-domain/

Thanks,

Solved Redirect issue!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.