Issue connecting Google Sheets with GCP Bitnami Odoo VM

Keywords: Odoo - Google Cloud Platform - Technical issue - Secure Connections (SSL/HTTPS)
bnsupport ID: e1d841a1-b1fd-97d0-26c7-9605925635cc

I am having a heck of a time figuring out how to connect my Odoo 14 server on a GCP VM to Google Sheets. The Odoo integration tool has an apps script on Google Sheets that tries to connect the sheet with the Odoo db. The db is postgres. I have tried whitelisting Google server IPs, updating app security settings in Google Admin Console, making sure my Google Apps Script ID is associated with my GCP Project, trying several username/passwords, among other things.

The Odoo integration asks for the following:

URL (with http:// or https://):
Database Name:

I have updated my firewall rules according to this article:

I have reviewed my odoo-server.conf file though I do not know if changes are needed here. These settings in the conf file seem important in this context:

db_host =
db_name = mydb
db_password = mypassword
db_port = 5432

http_enable = True
http_interface =
http_port = 8069

The Odoo server itself has some system parameters. Separate issues but may be related so I will mention: I thought I had correctly setup the Google Calendar and Google Drive integrations within Odoo, but just trying today the GCalendar import throws an error: “localhost refused to connect.” I have the GCP APIs with Client IDs and Secrets generated. I tried to set up the Google Authorization integration in Odoo as well, but I can’t figure that out so far either.
I have also tried connecting to the db using pgAdmin4.

I am doing something wrong trying to connect my Sheet to my Odoo db but I am not sure what. Would someone help me understand what is going on and/or troubleshoot?

Thank you so much for your help!

Hi @sw_365,

The issue exceeds the scope of this forum, which is for questions/issues related to the Bitnami configuration of the application. I recommend asking in an official Odoo forum.


Ok right on thank you Michiel!