Invalid Intermediate of HTTPS/SSL

Keywords: WordPress Multisite - Google Cloud Platform - Technical issue - Secure Connections (SSL/HTTPS)

bnsupport ID: 5f2a4aa4-5008-90c5-76f9-5a67f7cb5baf

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
? Wordpress: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

bndiagnostic failure reason: There’s a lot of errors with my server. Might come back again with a new request to attempt to learn how to troubleshoot these problems.

Description:
I just updated my multisite to force HTTPS. Everything seems to be working fine, however, I get the following error in WhyNoPadlock.com and I’m unsure how to resolve it:

Invalid Intermediate
You have an invalid or missing intermediate (bundle) certificate. This may not break your padlock on all browsers, but will on others. Please contact your SSL Vendor for assistance with this error.

Hello @gednav,

To add the intermediate certificate you will need to download the certificate of your cert issuer (R3) from their official website.

As such, you will need to execute the following:

cd /opt/bitnami/letsencrypt/certificates/
curl -JLO https://letsencrypt.org/certs/lets-encrypt-r3.pem

After that, you need to include the following directive in /opt/bitnami/apache2/conf/vhosts/wordpress-https-vhost.conf in both vhosts:

  SSLCertificateFile "/opt/bitnami/apache/conf/domain.com.crt"
  SSLCertificateKeyFile "/opt/bitnami/apache/conf/domain.com.key"
  SSLCertificateChainFile "/opt/bitnami/letsencrypt/certificates/lets-encrypt-r3.pem"

Save the changes and restart Apache before testing again your site.

Regards,
Francisco de Paz

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.