Internal Server Error – Grimlock for Buddypress

Keywords: WordPress Multisite - AWS - Technical issue - Other
Description:
Host: Bitnami / AWS Lightsail
Theme: Gwangi (Dating demo) from Themosauraus

Hi,

I just purchase Gwangi two days ago. Every time I enter: Appearance -> Customize I am reached with an Internal Server Error (see attached)

When I disable Grimlock for Buddypress, I am able to enter the Customizer but of course, the features don’t run properly.

When I disable Kirki Toolkit and keep Grimlock for Buddypress active, it works, but again, with limited functionality.

When I reached out the theme support, this is what they said:

  1. First please try to contact your hosting provider to see if they can help. Make sure to explain that you are having an internal server error, and not a PHP error.
  2. If they still redirect you to us, please include the Apache logs of your server so that I can take a look at those
  3. If you can, try to install your website on another server from another host to see if it works. And if it does, that gives you one more argument to send to the bitnami team to prove that the error is related to the server.

Hi @konmigoapp,

We have a Support Tool that will gather relevant information for us to analyze your configuration and logs. Could you please execute it on the machine where the stack is running by following the steps described in the guide below?

Please note that you need to paste the code ID that is shown at the end.

Regards,
Michiel

Hi Michiel,

I received the following message:

The support bundle file was successfully created, but the automatic upload to Bitnami servers failed. You will need to upload it to your Bitnami Support ticket manually. Please locate the following file in your file browser or in your terminal: [zip file name]

I cannot locate this file. Please let me know how I may go about doing so.

Hi @konmigoapp,

It should be in the /tmp folder. Can you tell me the output of this command:

ls /tmp/*zip 

Regards,
Michiel

/tmp/bitnami-wordpressmultisite-info-20210329-041300-12037.zip
Not sure where to go from here.

Hi @konmigoapp,

You can use FileZilla to download that file to your local machine and then send it to me through mail:

https://docs.bitnami.com/aws/faq/administration/upload-files/

I’ve shared my email address in a private message. You can send the file as an attachment. Please notify me here when you have sent the mail.

Regards,
Michiel

I did everything using Cyberduck, was able to connect, but no files appeared in the tmp folder

Hi @konmigoapp,

Can you move the file and try to download it from the user home folder?

mv /tmp/bitnami-wordpressmultisite-info-20210329-041300-12037.zip ~/

Regards,
Michiel

Received this error message

~/
mv: cannot move ‘/tmp/bitnami-wordpressmultisite-info-20210329-041300-12037.zip’ to ‘/home/
bitnami/bitnami-wordpressmultisite-info-20210329-041300-12037.zip’: Operation not permitted

Hi @konmigoapp,

You need to use sudo to move that file

sudo mv /tmp/bitnami-wordpressmultisite-info-20210329-041300-12037.zip ~/

Then you will be able to access the instance using a SFTP connection and download the package. Please upload it to a cloud storage platform later and share the link with us

https://docs.bitnami.com/aws/faq/administration/upload-files/

If you still have problems getting the file, please access the instance using a ssh connection and run this command so we can start taking a look at the Apache’s log file

sudo tail -n 30 /opt/bitnami/apache2/logs/error_log

Thanks

Hello,

It gave me an error message that I am unable to move the file

[Sun Mar 28 00:00:07.045400 2021] [ssl:warn] [pid 3134:tid 140428120577344] AH01882: Init: this version of mod_ssl
 was compiled against a newer library (OpenSSL 1.1.1i  8 Dec 2020, version currently loaded is OpenSSL 1.1.1g  21 
Apr 2020) - may result in undefined or erroneous behavior
[Sun Mar 28 00:00:07.049498 2021] [ssl:warn] [pid 3134:tid 140428120577344] AH01909: localhost:443:0 server certif
icate does NOT include an ID which matches the server name
[Sun Mar 28 00:00:07.152098 2021] [mpm_event:notice] [pid 3134:tid 140428120577344] AH00489: Apache/2.4.46 (Unix) 
OpenSSL/1.1.1g configured -- resuming normal operations
[Sun Mar 28 00:00:07.152115 2021] [core:notice] [pid 3134:tid 140428120577344] AH00094: Command line: '/opt/bitnam
i/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Sun Mar 28 00:00:07.152121 2021] [mpm_event:notice] [pid 3134:tid 140428120577344] AH00493: SIGUSR1 received.  Do
ing graceful restart
[Sun Mar 28 00:00:07.176807 2021] [ssl:warn] [pid 3134:tid 140428120577344] AH01882: Init: this version of mod_ssl
 was compiled against a newer library (OpenSSL 1.1.1i  8 Dec 2020, version currently loaded is OpenSSL 1.1.1g  21 
Apr 2020) - may result in undefined or erroneous behavior
[Sun Mar 28 00:00:07.178722 2021] [ssl:warn] [pid 3134:tid 140428120577344] AH01909: localhost:443:0 server certif
icate does NOT include an ID which matches the server name
[Sun Mar 28 00:00:07.200693 2021] [mpm_event:notice] [pid 3134:tid 140428120577344] AH00489: Apache/2.4.46 (Unix) 
OpenSSL/1.1.1g configured -- resuming normal operations
[Sun Mar 28 00:00:07.200707 2021] [core:notice] [pid 3134:tid 140428120577344] AH00094: Command line: '/opt/bitnam
i/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf'
[Sun Mar 28 05:00:44.401189 2021] [pagespeed:error] [pid 29182:tid 140426774279936] [mod_pagespeed 1.13.35.2-0 @29
182] PageSpeed Serf fetch failure rate extremely high; only 0 of 96 recent fetches fully successful; is fetching w
orking?
[Sun Mar 28 17:13:24.777212 2021] [pagespeed:error] [pid 29182:tid 140426774279936] [mod_pagespeed 1.13.35.2-0 @29
182] PageSpeed Serf fetch failure rate extremely high; only 0 of 96 recent fetches fully successful; is fetching working?
[Mon Mar 29 07:47:16.955426 2021] [pagespeed:error] [pid 28629:tid 140426816243456] [mod_pagespeed 1.13.35.2-0 @28
629] PageSpeed Serf fetch failure rate extremely high; only 0 of 96 recent fetches fully successful; is fetching w
orking?
[Mon Mar 29 16:05:30.450010 2021] [pagespeed:error] [pid 29182:tid 140426774279936] [mod_pagespeed 1.13.35.2-0 @29
182] PageSpeed Serf fetch failure rate extremely high; only 0 of 281 recent fetches fully successful; is fetching 
working?
[Mon Mar 29 20:40:55.446945 2021] [pagespeed:error] [pid 29182:tid 140426774279936] [mod_pagespeed 1.13.35.2-0 @29
182] PageSpeed Serf fetch failure rate extremely high; only 0 of 96 recent fetches fully successful; is fetching w
orking?
[Tue Mar 30 01:49:52.927161 2021] [authz_core:error] [pid 28628:tid 140427503953664] [client 54.234.71.208:52448] 
AH01630: client denied by server configuration: /opt/bitnami/apps/phpmyadmin/htdocs/
[Tue Mar 30 04:36:49.421853 2021] [pagespeed:error] [pid 29182:tid 140426774279936] [mod_pagespeed 1.13.35.2-0 @29
182] PageSpeed Serf fetch failure rate extremely high; only 0 of 96 recent fetches fully successful; is fetching w
orking?
[Tue Mar 30 16:42:50.449211 2021] [pagespeed:error] [pid 29182:tid 140426774279936] [mod_pagespeed 1.13.35.2-0 @29
182] PageSpeed Serf fetch failure rate extremely high; only 0 of 96 recent fetches fully successful; is fetching w
orking?
[Wed Mar 31 04:12:57.014075 2021] [pagespeed:error] [pid 29182:tid 140426774279936] [mod_pagespeed 1.13.35.2-0 @29
182] PageSpeed Serf fetch failure rate extremely high; only 0 of 96 recent fetches fully successful; is fetching w
orking?
[Wed Mar 31 12:20:46.919762 2021] [pagespeed:error] [pid 28629:tid 140426816243456] [mod_pagespeed 1.13.35.2-0 @28
629] PageSpeed Serf fetch failure rate extremely high; only 0 of 96 recent fetches fully successful; is fetching w
orking?
[Wed Mar 31 16:07:12.293300 2021] [pagespeed:error] [pid 29182:tid 140426774279936] [mod_pagespeed 1.13.35.2-0 @29
182] PageSpeed Serf fetch failure rate extremely high; only 0 of 14 recent fetches fully successful; is fetching working?

Hi @konmigoapp,

Is it possible that the file isn’t present on your server anymore? Please try running the bnsupport tool again. Let’s see if the auto-upload feature works now.

Those error messages you shared usually mean your server is running out of free memory. We recommend you to disable PageSpeed as explained in the next guide

https://docs.bitnami.com/aws/apps/wordpress/administration/use-pagespeed/#disable-pagespeed

Apart from that, can you run the next commands on your server and share the output?

sudo df -h
sudo free -m

Hello,

I ran the bnsupport tool again:

The support bundle file was successfully created, but the automatic upload to Bitnami serve
rs failed. You will need to upload it to your Bitnami Support ticket manually. Please locat
e the following file in your file browser or in your terminal: /tmp/bitnami-wordpressmultis
ite-info-20210401-141547-18237.zip Exercise caution when uploading the resulting support bu
ndle to public sites as it contains detailed diagnostic information.

Filesystem Size Used Avail Use% Mounted on
udev 233M 0 233M 0% /dev
tmpfs 49M 5.3M 44M 11% /run
/dev/xvda1 20G 3.5G 16G 19% /
tmpfs 242M 0 242M 0% /dev/shm
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 242M 0 242M 0% /sys/fs/cgroup
/dev/xvda15 124M 278K 124M 1% /boot/efi
tmpfs 49M 0 49M 0% /run/user/1000

          total        used        free      shared  buff/cache   available

Mem: 482 178 132 51 172 240
Swap: 634 570 64

Can you provide step-by-step instructions for disabling pagespeed?

Note, i have no experience whatever with code

Hello @konmigoapp,

To disable PageSpeed, follow these steps:

  • Access your instance via SSH

  • Comment out the following lines in the /opt/bitnami/apache2/conf/httpd.conf file:

  #Include conf/pagespeed.conf
  #Include conf/pagespeed_libraries.conf

In order to edit the file mentioned in this step, you can open it with this command:

sudo nano /opt/bitnami/apache2/conf/httpd.conf
  • Restart Apache:
sudo /opt/bitnami/ctlscript.sh restart apache 

I hope it helps

Unmonitored apache
Syntax OK
/opt/bitnami/apache2/scripts/ctl.sh : httpd stopped
Syntax OK
/opt/bitnami/apache2/scripts/ctl.sh : httpd started at port 80
Monitored apache

I was able to command out those lines, restart Apache and got that message^

I enabled Grimlock for Buddypress, and still cannot customize my website. So it didn’t work

Hi
I have the same problem. When accessing Appearance> Customize, there is an Internal Server Error.

I use bitnami-wordpress-5.7-2-linux-debian-10-x86_64-hvm-ebs-7d426cb7-9522-4dd7-a56b-55dd8cc1c8d0 under t2.micro instance

sudo tail -n 30 /opt/bitnami/apache2/logs/error_log
[Thu Apr 01 13:15:04.836645 2021] [mpm_event:notice] [pid 1047:tid 140128157504832] AH00489: Apache/2.4.46 (Unix) OpenSSL/1.1.1i configured – resuming normal operations
[Thu Apr 01 13:15:04.836679 2021] [core:notice] [pid 1047:tid 140128157504832] AH00094: Command line: ‘/opt/bitnami/apache2/bin/httpd.bin -f /opt/bitnami/apache2/conf/httpd.conf’
[Thu Apr 01 13:15:30.196133 2021] [substitute:error] [pid 1245:tid 140127854647040] [client 172.68.25.145:47828] AH01328: Line too long, URI /wp-admin/customize.php, referer: http://primeluxxsemijoias.com.br/wp-admin/index.php
[Thu Apr 01 13:15:30.196176 2021] [proxy_fcgi:error] [pid 1245:tid 140127854647040] (12)Cannot allocate memory: [client 172.68.25.145:47828] AH01075: Error dispatching request to : (passing brigade to output filters), referer: http://primeluxxsemijoias.com.br/wp-admin/index.php
[Thu Apr 01 13:16:40.221857 2021] [substitute:error] [pid 1053:tid 140127737149184] [client 172.68.24.134:32928] AH01328: Line too long, URI /wp-admin/customize.php, referer: http://primeluxxsemijoias.com.br/wp-admin/options-general.php
[Thu Apr 01 13:16:40.221914 2021] [proxy_fcgi:error] [pid 1053:tid 140127737149184] (12)Cannot allocate memory: [client 172.68.24.134:32928] AH01075: Error dispatching request to : (passing brigade to output filters), referer: http://primeluxxsemijoias.com.br/wp-admin/options-general.php
[Thu Apr 01 13:19:37.171661 2021] [substitute:error] [pid 1245:tid 140127544116992] [client 172.68.24.134:40198] AH01328: Line too long, URI /wp-admin/customize.php, referer: http://primeluxxsemijoias.com.br/wp-admin/themes.php
[Thu Apr 01 13:19:37.171709 2021] [proxy_fcgi:error] [pid 1245:tid 140127544116992] (12)Cannot allocate memory: [client 172.68.24.134:40198] AH01075: Error dispatching request to : (passing brigade to output filters), referer: http://primeluxxsemijoias.com.br/wp-admin/themes.php

Help me please
Thanks

Hi @konmigoapp,

If you disabled PageSpeed, did you find any other issue in the Apache’s log?

sudo tail -n 30 /opt/bitnami/apache2/logs/error_log

If there is not any new error there, please contact the plugin’s developers to know more about the issues you are running into.