Installed themes don't work

If you install a theme on the Bitnami Lifray instance, you will not be able to use it on your sites since theme resources are not served by Apache.

I have tried installing the Liferay themes from the market and from a downloaded archive package, but the result is the same.

The theme’s webapp gets deployed into the tomcat/webapps folder and Tomcat loads them as web applications. However, when you assign the theme to a site in Liferay, the site will not display properly because the browser gets 404 responses from Apache for the JS and CSS and image files (static resources).

Sidenote: I also had to fix a JAI classnotfound error as well to make themes deploy, but that is a separate issue.

The problem can be worked around by manually adding entries to the apps/liferay/confhttpd-app.conf file.

For example, for the Chroma theme, add this:

<Location /chroma-theme>
ProxyPass ajp://localhost:8009/chroma-theme

The added location must be the same as the name of the subfolder for the theme in apache-tomcat/webapps.

Hi @asoltesz,

We’re glad you solved the issue and we want to thank you for also taking the time to share it here.

Please don’t hesitate to write back if you find any other issue.

Best regards,
Alvaro