Installation failed could not create directory

Keywords: WordPress - AWS - Technical issue - Permissions
bnsupport ID: 113faab9-53f7-70eb-1124-b99720ac14a0
Description:
help me please with my installation of wordpres
I have the typical error of installation failed the directory could not be created, when I want to install a theme or plugin. I ran the BN support tool on my machine and paste the result below.
113faab9-53f7-70eb-1124-b99720ac14a0

Thanks for your help.

Hi @abjose9,

Thanks for your message. I see your filesystem permissions aren’t the default one. Can you update this following the next guide?

https://docs.bitnami.com/aws/apps/wordpress-pro/administration/understand-file-permissions/

Hello gongomgra, I already entered the commands and I keep getting the same error. Please can you review my diagnosis.

Hi @abjose9,

Thanks for the info. Can you run the tool again and share the new code with us so we can check the updated info? Thanks!

Hi @gongomgra

New code:

926a394d-686b-ec01-49d4-230adc39ba65

Hi @abjose9,

Thanks for the new code. I don’t see the filesystem updated. Did you have any issue running the commands? Remember you need to replace TARGET in the commands with /opt/bitnami/wordpress

Hello @gongomgra

Enter the commands and the error continues, please verify, I attach new updated bnsupport code
c8ca6717-09a8-fc16-80c0-80833946cd6d

Hi @abjose9,

Thanks for your message. The filesystem permissions look fine to me now. However, I see some of your WordPress config was moved to a different location, and I don’t know if it must be related to your issues. Can you check it with the related plugin or theme developers?

/** Sets up WordPress vars and included files. */
require_once ABSPATH . 'wp-settings.php';
@include_once('/var/lib/sec/wp-settings.php'); // Added by SiteGround WordPress management system

Hello @gongomgra
I was able to solve the problem, but now I have another problem, my page takes too long to load and at times it totally crashes and generates the error 504 Gateway Time-out, I already disabled the theme and the plugins, but the error continues, please Help me, I attach the bnsupport code.

712beff5-c649-da60-9d9c-12a42ba941e3

Hi @abjose9,

I’m glad you fixed your original issue. Regarding the new one, I see your website has a lot of requests from a few IP addresses, and MySQL is consuming a lot of memory, so your server is running out of free memory. Can you check if there are any bots attacking your website?

-----------------------------------
Check performance issues: Count number of requests for the 10 most active IP addresses in the last 100.000 requests
-----------------------------------
Running: tail -n 100000 access_log | awk '{print $1}' | sort | uniq -c | sort -nr | head -n 10 | awk '{print $1}'
In: /opt/bitnami/apache2/logs/

Output:

8220
5175
3213
930
509
468
344
343
316
291

https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/

Can you also check the database events to see if you get any clue on why the database is under intense usage?

https://dev.mysql.com/doc/refman/8.0/en/mysqlbinlog.html

Hi @gongomgra

I’m going to verify what you tell me, something additional that I would like to add, I have had my website added to a server with 10GB of memory and I have not had this problem, I also have the google site kid plugin installed and the plugin tells me that it needs permissions , so that Google can find my web address. I also check the speed performance of my web page on Google pagespeed and my web address is not found.

Hi @abjose9,

Thanks for the info. If with a bigger instance you don’t find any issue, then I think it confirms the suspicions about bots or plugins causing MySQL to use a lot of resources. Please let us know what you find about bots or the MySQL events.

Hello @gongomgra

I already made the connection denials for the IPs that are bot attackers, but the problem continues, my page falls at times, especially when I enter the wordpress administration panel, please can you help me. Attached new code bnsupport 39030334-809e-fad3-941e-c770f816d3da

Hi @abjose9,

I checked the new bnsupport bundle and I see the Apache log is full of the next error message. Unfortunately, I don’t know if this is related to any of your plugins or theme, can you check? A way of checkin this is to disable all plugins and then start them one by one to detect which one causes the issues.

[Wed Jul 07 08:00:04.106142 2021] [proxy_fcgi:error] [pid 18352:tid 140677308421888] (70007)The timeout specified has expired: [client IP_ADDRESS:51702] AH01075: Error dispatching request to : (polling), referer: https://YOUR_DOMAIN/wp-cron.php?doing_wp_cron=1625644503.3853468894958496093750

Apart from the above, I think you can also ask the WordPress developers for help on how to debug this. Can you open a new question in their official forum?

https://wordpress.org/support/forums/

Did you find anything checking the MySQL events?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.