Installation error: dyld: Library not loaded

Keywords: PostgreSQL - OS X - Technical issue - Other
Description:
I just installed MAMP on Catalina and want to install Postgresqladdon Module.app so I can add MediaWiki onto MAMP but the module installer throws an error. When the addon module gets to

installing
Creating link /Applic[…]mpstack-7.3.13-0/postgresql/lib/libecpg.dylib

an error comes up saying:

There has been an error.
dyld: Library not loaded: /bitnami/mamp71stack-osx-64/output/common/lib/libssl.1.0.0.dylib
Referenced from: /Applications/mampstack-7.3.13-0/postgresql/lib/libpq.5.10.dylib
Reason: image not found

The installer exits without finishing.

I ran the Bitnami support tool but the automatic upload failed. I’m not sure how to manually add it to the ticket as per the instructions.

Hi @Grz44,

We have the the OS X Mediawiki standalone VM, which is easy to install and manage. Would that work for you?

Regards,
Michiel

Thanks for that. I have no problem with installing them separately. I’ll do that then.

Hi @Grz44,

Thanks for the info. Let us know if you find any issue using our OS X VM solution.

Best regards,
Gonzalo

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.