Install Shibboleth

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Plugins installation/configuration

bndiagnostic ID: 05e68dcc-7d87-b56a-5549-32a48edf3f29

bndiagnostic output:

? Apache: Found possible issues
? Resources: Found possible issues
? Php: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/general/apps/wordpress/configuration/configure-phpfpm-processes/

Description:
Is there a way to install Shibboleth on the AWS Lightsail Bitnami stack? I tried to install it using “sudo apt-get install libapache2-mod-shib2” but I can’t enable the module in Apache as it’s not listed on the httpd.conf file.

Please advise, thanks!

Hi @ubay25,

We do not use the sytem packages to install Apache and that’s why you can’t use apt to install that module. You need to build the library in the instance and then load the .so file in the Apache’s configuration

https://shibboleth.atlassian.net/wiki/spaces/SP3/pages/2065335062/Apache

Please nota this is a specific question about the application so we suggest you ask in the official forums of the application to get more information about that. The library’s documentation should also describe how to achieve what you want to, so please take a look at it too.

However, we will also keep this ticket open in this forum in case any Bitnami user configured the application they way you want to.

Thanks

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.