Install Owncloud 10-0-7-1 fail on Ubuntu 17.1 server with stacker Bitnami 7-1-15-0

Keywords: OwnCloud - Linux - Technical issue - Other
Description:
At the end of install i have the message :

Error running /opt/lampstack-7.1.15-0/apps/owncloud/scripts/owncloudinstall.sh
:
  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.

  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.

  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.

Press [Enter] to continue:
#

----------------------------------------------------------------------------
Setup has finished installing Bitnami ownCloud Module on your computer.

And i can not run from browser.
My PC is with CPU AMD 9590, 16 or 8 Gb RAM, tested on two PC, same problem.
Wordpress, Joomla, Drupal run correctly on the same Ubuntu server

Thanks, regards.

Hello @plhmk11

I was unable to reproduce the issue on a clean installation of LAMP Stack (7.1.15). See the results:

$ sudo ./bitnami-owncloud-10.0.7-1-module-linux-x64-installer.run
----------------------------------------------------------------------------
Welcome to the Bitnami ownCloud Module Setup Wizard.

----------------------------------------------------------------------------
Installation folder

Please choose a folder that contains an installation of Bitnami.

Select a folder []: /opt/lampstack-7.1.15-0

----------------------------------------------------------------------------
Create Admin account

Login [user]:

Your real name [User Name]:

Email Address [user@example.com]:

Please enter the MySQL password for "root" for the existing Bitnami installation

Password :

----------------------------------------------------------------------------
ownCloud

Please configure ownCloud installation

Hostname that will be used to create internal URLs. If this value is incorrect,
you may be unable to access your ownCloud installation from other computers.

Hostname [X.X.X.X]:

Do you want to configure mail support? [y/N]:

----------------------------------------------------------------------------
Setup is now ready to begin installing Bitnami ownCloud Module on your computer.

Do you want to continue? [Y/n]:

----------------------------------------------------------------------------
Please wait while Setup installs Bitnami ownCloud Module on your computer.

 Installing
 0% ______________ 50% ______________ 100%
 #########################################

----------------------------------------------------------------------------
Setup has finished installing Bitnami ownCloud Module on your computer.

Launch Bitnami ownCloud Module [Y/n]: n

Did you install the ownCloud module as superuser (sudo)?

Best Regards,

Juan Ariza


Was my answer helpful? Click on :heart:

Hello ,
this is my procedure with error (use sudo)

 pl@pl-srv-bitnami:/tmp$ sudo ./bitnami-owncloud-10.0.7-1-module-linux-x64-installer.run
----------------------------------------------------------------------------
Welcome to the Bitnami ownCloud Module Setup Wizard.

----------------------------------------------------------------------------
Installation folder

Please choose a folder that contains an installation of Bitnami.

Select a folder []: /opt/lampstack-7.1.15-0

Note: You should select the previous installation of Bitnami. For example:
/opt/bitnami



----------------------------------------------------------------------------
Create Admin account

Please enter the MySQL password for "root" for the existing Bitnami installation

Password :

----------------------------------------------------------------------------
ownCloud

Please configure ownCloud installation

Hostname that will be used to create internal URLs. If this value is incorrect,
you may be unable to access your ownCloud installation from other computers.

Hostname [127.0.1.1]: X.X.X.X  (my IP server adress)

Do you want to configure mail support? [y/N]:

----------------------------------------------------------------------------
Setup is now ready to begin installing Bitnami ownCloud Module on your computer.

Do you want to continue? [Y/n]:

----------------------------------------------------------------------------
Please wait while Setup installs Bitnami ownCloud Module on your computer.

 Installing
 0% ______________ 50% ______________ 100%
 ########################################Warning: Problem running post-install step. Installation may not complete
correctly
 Error running /opt/lampstack-7.1.15-0/apps/owncloud/scripts/owncloudinstall.sh
:

  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.




  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.




  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.


Press [Enter] to continue:

Thanks, regards

Try also with the new bitnami stacker 7.1.16-0, with last oC version 10.0.7-1 (module) in different PC with Ubuntu 17.1, evrithing same error, and don’t start…
Regards

Hi @plhmk11,

We just tried to reproduce the issue again in a fresh Ubuntu 17.10 virtual machine from osboxes.org and everything went fine during the installation process. In order to obtain more information about the issue, could you please share with us the installation log?

ls -lart /tmp/bitrock_*.log

You will need to take the last one of that list and share its content with us.[quote=“plhmk11, post:3, topic:56672”]
Hostname that will be used to create internal URLs. If this value is incorrect,
you may be unable to access your ownCloud installation from other computers.

Hostname [127.0.1.1]: X.X.X.X (my IP server adress)

Do you want to configure mail support? [y/N]:
[/quote]

Regarding the IP of your server, is the Apache server remotely accessible when using your public IP?

Thanks.

Hello,
i have this error if i try…:slight_smile:

pl@pl-srv-bitnami:~$ ls -lart /tmp/bitrock_.log
ls: impossibile accedere a '/tmp/bitrock_
.log’: File o directory non esistente
pl@pl-srv-bitnami:~$

Hi @plhmk11,

Please note that the /tmp folder is a temporary folder and it’s removed every time you power off or restart your machine. In case you did it, could you please try to install the module again and share the log file with us?

Thanks.

Hello, attached two log files: ( i can not upload file)…
Thanks, regards.

 pl@pl-srv-bitnami:/tmp$ sudo cat bitrock_installer.log
Log started 04/10/2018 at 13:25:44
Preferred installation mode : qt
Trying to init installer in mode qt
Trying to init installer in mode qt
Trying to init installer in mode gtk
Trying to init installer in mode xwindow
Trying to init installer in mode text
Mode text successfully initialized
Executing /opt/lampstack-7.1.16-0/mysql/bin/mysql -u root -p**** -P3306 -hlocalhost -e "show databases;"
Script exit code: 1

Script output:


Script stderr:
 mysql.bin: [Warning] Using a password on the command line interface can be insecure.
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/lampstack-7.1.16-0/mysql/tmp/mysql.sock' (2)

Error running /opt/lampstack-7.1.16-0/mysql/bin/mysql -u root -p**** -P3306 -hlocalhost -e "show databases;": mysql.bin: [Warning] Using a password on the command line interface can be insecure.
ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/opt/lampstack-7.1.16-0/mysql/tmp/mysql.sock' (2)
pl@pl-srv-bitnami:/tmp$

pl@pl-srv-bitnami:/tmp$ sudo cat bitrock_installer_1871.log
Log started 04/10/2018 at 13:27:43
Preferred installation mode : qt
Trying to init installer in mode qt
Trying to init installer in mode qt
Trying to init installer in mode gtk
Trying to init installer in mode xwindow
Trying to init installer in mode text
Mode text successfully initialized
Executing /opt/lampstack-7.1.16-0/mysql/bin/mysql -u root -p**** -P3306 -hlocalhost -e "show databases;"
Script exit code: 0

Script output:
 Database
information_schema
bitnami_owncloud
bitnami_wordpress
mysql
performance_schema
sys

Script stderr:
 mysql.bin: [Warning] Using a password on the command line interface can be insecure.

Preparing to Install
Preparing to Install
Unpacking files
Unpacking files
Unpacking files
Creating databases - this may take a minute
Executing /opt/lampstack-7.1.16-0/php/bin/php -c "/opt/lampstack-7.1.16-0/php/etc" "/opt/lampstack-7.1.16-0/apps/owncloud/scripts/createdb.php"
Script exit code: 0

Script output:


Script stderr:


Executing /opt/lampstack-7.1.16-0/ctlscript.sh stop apache > /dev/null 2> /dev/null
Script exit code: 0

Script output:


Script stderr:


Executing /opt/lampstack-7.1.16-0/ctlscript.sh start apache > /dev/null 2> /dev/null
Script exit code: 0

Script output:


Script stderr:


Executing /opt/lampstack-7.1.16-0/apps/owncloud/scripts/owncloudinstall.sh
Script exit code: 1

Script output:
 ownCloud is not installed - only a limited number of commands are available
ownCloud is not installed - only a limited number of commands are available
ownCloud is not installed - only a limited number of commands are available

Script stderr:


  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.




  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.




  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.



Error running /opt/lampstack-7.1.16-0/apps/owncloud/scripts/owncloudinstall.sh :

  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.




  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.




  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.


Problem running post-install step. Installation may not complete correctly
 Error running /opt/lampstack-7.1.16-0/apps/owncloud/scripts/owncloudinstall.sh :

  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.




  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.




  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.


Creating Uninstaller
Creating uninstaller 25%
Creating uninstaller 50%
Creating uninstaller 75%
Creating uninstaller 100%
Installation completed
Log finished 04/10/2018 at 13:29:01
Launching http://127.0.0.1:80/owncloud
pl@pl-srv-bitnami:/tmp$

Hi @plhmk11

It seems it’s failing when executing the script below during the installation:

#!/bin/bash
. /opt/lampstack-7.1.16-0/scripts/setenv.sh
/opt/lampstack-7.1.16-0/php/bin/php /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/occ -q maintenance:install --database "mysql" --database-name "bitnami_owncloud"  --database-host "127.0.0.1:3306" --database-user "bn_owncloud" --database-pass "XXXXXX" --admin-user "user" --admin-pass "YYYYYY" --data-dir "/opt/lampstack-7.1.16-0/apps/owncloud/data"
/opt/lampstack-7.1.16-0/php/bin/php /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/occ -q config:system:set trusted_domains 0 --value="127.0.0.1"
/opt/lampstack-7.1.16-0/php/bin/php /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/occ -q config:system:set trusted_domains 1 --value="X.X.X.X"
/opt/lampstack-7.1.16-0/php/bin/php /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/occ -q config:system:set openssl config --value=" /opt/lampstack-7.1.16-0/common/openssl/openssl.cnf"

For some reason the “occ” commands are failing.

According to this topic:

https://forum.owncloud.org/viewtopic.php?t=37582

The problem could be related with the maintenance mode to be activated. Could you run the commands below to see if you find any issue?

sudo -u daemon /opt/lampstack-7.1.16-0/php/bin/php /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/occ maintenance:mode --off
sudo -u daemon /opt/lampstack-7.1.16-0/php/bin/php /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/occ -q config:system:set trusted_domains 0 --value="127.0.0.1"

Best Regards,

Juan Ariza


Was my answer helpful? Click on :heart:

Hello,

Here’s the output required:

pl@pl-srv-bitnami:~$ sudo -u daemon /opt/lampstack-7.1.16-0/php/bin/php /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/occ maintenance:mode --off
[sudo] password di pl:
PHP Warning:  fopen(/opt/lampstack-7.1.16-0/apps/owncloud/htdocs/config/config.php): failed to open stream: Permission denied in /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/private/Config.php on line 208
PHP Warning:  flock() expects parameter 1 to be resource, boolean given in /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/private/Config.php on line 218
An unhandled exception has been thrown:
Exception: Could not acquire a shared lock on the config file /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/config/config.php in /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/private/Config.php:219
Stack trace:
#0 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/private/Config.php(63): OC\Config->readData()
#1 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/base.php(134): OC\Config->__construct('/opt/lampstack-...')
#2 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/base.php(517): OC::initPaths()
#3 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/base.php(998): OC::init()
#4 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/console.php(64): require_once('/opt/lampstack-...')
#5 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/occ(11): require_once('/opt/lampstack-...')
#6 {main}pl@pl-srv-bitnami:~$ sudo -u daemon /opt/lampstack-7.1.16-0/php/bin/php /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/occ -q config:system:set trusted_domains 0 --value="127.0.0.1"
PHP Warning:  fopen(/opt/lampstack-7.1.16-0/apps/owncloud/htdocs/config/config.php): failed to open stream: Permission denied in /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/private/Config.php on line 208
PHP Warning:  flock() expects parameter 1 to be resource, boolean given in /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/private/Config.php on line 218
An unhandled exception has been thrown:
Exception: Could not acquire a shared lock on the config file /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/config/config.php in /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/private/Config.php:219
Stack trace:
#0 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/private/Config.php(63): OC\Config->readData()
#1 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/base.php(134): OC\Config->__construct('/opt/lampstack-...')
#2 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/base.php(517): OC::initPaths()
#3 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/lib/base.php(998): OC::init()
#4 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/console.php(64): require_once('/opt/lampstack-...')
#5 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/occ(11): require_once('/opt/lampstack-...')
#6 {main}pl@pl-srv-bitnami:~$

Thanks, regards

Hi @plhmk11

It seems the issue is related with lack of permissions on OwnCloud configuration file. The user daemon is unable to lock it and, therefore, it can’t configure it.

Could you run the command below and share the output?

ls -la /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/config/config.php

Sorry for this try/check iterations but I’m unable to reproduce it on my side and it’s pretty hard to determine the reason why it’s failing on your Ubuntu server.

Best Regards,

Juan Ariza


Was my answer helpful? Click on :heart:

Here the output

pl@pl-srv-bitnami:~$ ls -la /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/config/config.php
-rw-r----- 1 root root 592 apr 10 13:28 /opt/lampstack-7.1.16-0/apps/owncloud/htdocs/config/config.php
pl@pl-srv-bitnami:~$

No problem for ask me :slight_smile:
Thanks for your help…:relaxed:

Hi @plhmk11

As you can check the ownership of that file is root:root with 640 permissions. That’s the reason why the user daemon (the one running the configuration commands) is unable to modify the settings available there.

Could you try using the ownCloud module below? It’s a modified version a created to check if we can workaround the issue.

https://downloads.bitnami.com/files/owncloud/bitnami-owncloud-10.0.7-1-module-linux-x64-installer.run
md5: cc731079c42f4ca9ce2e4d835bf4f813

Best Regards,

Juan Ariza


Was my answer helpful? Click on :heart:

Hello,
this is better but everithing i have one error when installing, as follow::confused:
Also, i don’t understand why only me i have this error…:cry:
If needed i can reinstall all bitnami stack…:neutral_face:
Thanks, regards

Do you want to continue? [Y/n]:

----------------------------------------------------------------------------
Please wait while Setup installs Bitnami ownCloud Module on your computer.

 Installing
 0% ______________ 50% ______________ 100%
 ########################################
Warning: Problem running post-install step. Installation may not complete
correctly
 
Error running chown -R root:bitnami /opt/lampstack-7.1.16-0/apps/owncloud/data:
chown: gruppo non valido: "root:bitnami"
Press [Enter] to continue:
#

----------------------------------------------------------------------------
Setup has finished installing Bitnami ownCloud Module on your computer.

Launch Bitnami ownCloud Module [Y/n]:

Hello @plhmk11

If needed i can reinstall all bitnami stack…

Yes, please. Reinstall the LAMP stack and try installing the new module I shared with you. Please install both the stack and the module using “sudo”.

Best Regards,

Juan Ariza

Hello,
Reinstalled all (Linux server, stacker and owncloud) … but same error…

pl@pl-srv-bitnami:~$ sudo ./bitnami-owncloud-10.0.7-1-module-linux-x64-installer.run
----------------------------------------------------------------------------
Welcome to the Bitnami ownCloud Module Setup Wizard.

----------------------------------------------------------------------------
Installation folder

Please choose a folder that contains an installation of Bitnami.

Select a folder []: /opt/lampstack-7.1.16-0

Note: You should select the previous installation of Bitnami. For example:
/opt/bitnami

----------------------------------------------------------------------------
Create Admin account

Please enter the MySQL password for "root" for the existing Bitnami installation

Password :

----------------------------------------------------------------------------
ownCloud

Please configure ownCloud installation

Hostname that will be used to create internal URLs. If this value is incorrect,
you may be unable to access your ownCloud installation from other computers.

Hostname [127.0.1.1]:

Do you want to configure mail support? [y/N]:

----------------------------------------------------------------------------
Setup is now ready to begin installing Bitnami ownCloud Module on your computer.

Do you want to continue? [Y/n]:

----------------------------------------------------------------------------
Please wait while Setup installs Bitnami ownCloud Module on your computer.

 Installing
 0% ______________ 50% ______________ 100%
 ########################################
Warning: Problem running post-install step. Installation may not complete correctly
 Error running chown -R root:bitnami /opt/lampstack-7.1.16-0/apps/owncloud/data:
chown: gruppo non valido: "root:bitnami"
Press [Enter] to continue:
#

----------------------------------------------------------------------------
Setup has finished installing Bitnami ownCloud Module on your computer.

Launch Bitnami ownCloud Module [Y/n]:

Also, when i start the stacker the launcher “freeze” at startup, i need give a ^C for exit …
But is running…

Also owncloud config.php for me is “incomplete”…:

pl@pl-srv-bitnami:/opt/lampstack-7.1.16-0/apps/owncloud/htdocs/config$ sudo cat config.php
[sudo] password di pl:
<?php
$CONFIG = array (
  'instanceid' => 'oc5y9k17txl0',
);

Regards

Hi,

After reinstall your LAMP, do you also tried to install the “default” Owncloud module instead of the one provided by @jariza?

Best regards,
Carlos R. Hernández

Hello, also with default Owncloud module i have the same “original” error :confused:

Please wait while Setup installs Bitnami ownCloud Module on your computer.

 Installing
 0% ______________ 50% ______________ 100%
 ########################################Warning: Problem running post-install step. Installation may not complete
correctly
 Error running /opt/lampstack-7.1.16-0/apps/owncloud/scripts/owncloudinstall.sh
:
  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.

  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.

  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.

Press [Enter] to continue:

Regards

Hello @plhmk11

Let’s try a different approach. Could you try to uninstall the LAMP stack and install the Owncloud Stack (not the module) on your system?

You can download the stack installer from the link below:

https://downloads.bitnami.com/files/stacks/owncloud/10.0.7-1/bitnami-owncloud-10.0.7-1-linux-x64-installer.run

Please note that ownCloud stack is also a LAMP so you’ll be able to install other modules on top of it as you did previously with WordPress, Joomla!, Drupal, etc.

Best Regards,

Juan Ariza


Was my answer helpful? Click on :heart:

Hello,
also with install Owncloud stack (no module, developer mode) on a “new” ubuntu server i have same error:

 Installing
 0% ______________ 50% ______________ 100%
 ########################################Warning: Problem running post-install step. Installation may not complete
correctly
 Error running /opt/owncloud-10.0.7-1/apps/owncloud/scripts/owncloudinstall.sh :

  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.


  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.

  [Symfony\Component\Console\Exception\CommandNotFoundException]
  There are no commands defined in the "config:system" namespace.

Regards.