I want to run multisites which are wordpress sites

Keywords: LAMP/MAMP/WAMP - AWS - Technical issue - Application configuration

bnsupport ID: f895bb89-1ac7-d507-0740-01b91ae5f9c9

bndiagnostic output:

? Apache: Found possible issues
? Mariadb: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/general/how-to/troubleshoot-permission-issues/

bndiagnostic failure reason: The suggested guides are not related with my issue

Description:
I’m unable to access my wordpress sites though by entering server IP I’m able to access my 1 WP site I’m here to use 2 sites from a domain but when I enter http://server-IP/site2 it shows Page not found error.

Regards
Fran

Multiple Sites setup through single WP-Admin, that’s all i want.

Hi @kirbyfran56,

If you deployed the regular WordPress solution, you can only have 1 site. However, you have different options here:

  • Deploy a WordPress Multisite solution to be able to generate multiple sites from the same application
  • Deploy a second WordPress application in the same server you have your current deployment so you have 2 different WordPress sites

https://docs.bitnami.com/aws/apps/wordpress/administration/create-custom-application-php/

Happy to help!


Was my answer helpful? Click on :heart:

1 Like

How to deploy a WordPress Multisite Solution?I deployed a wordpress, Test and Test2 in /opt/bitnami but unable to access all folders only Test is accessible.

Hi @kirbyfran56,

You have more information about where to launch the Multisite solution here:

https://bitnami.com/stack/wordpress-multisite/cloud

Happy to help!


Was my answer helpful? Click on :heart:

1 Like

Can you please provide me solution of the issue I mentioned i.e. /opt/bitnami/Test2 one why it is not accessible?

I’m able to access only my Test Site which is in ( /opt/Bitnami/myapp).

And according to the link you provided yesterday I did as you asked for.

Nonetheless nothing working as suggested by you yesterday i.e. I’m able to open Test Folder only which is in /opt/Bitnami/Test.

Please give a look to it as it is an Urgent Case.

Thanks & Regards
Fran Kirby

Hi @kirbyfran56,

Please note that both virtual hosts you created in the /opt/bitnami/apache/conf/vhosts/ folder use ServerAlias *, that means that no matter the domain you use, that’s a valid VirtualHost. Having said that, as you do not have different domains configured for those VirtualHosts, all requests use the first one that is the WordPress’ one.

If you want to use a folder instead of a subdomain when accessing the application, please edit both wordpress-vhost.conf and wordpress-https-vhost.conf files and set these lines

<VirtualHost 127.0.0.1:80 _default_:80>
  ServerAlias *
  DocumentRoot /opt/bitnami/wordpress

  Alias /Test2 /opt/bitnami/Test2
  Alias /Test2/ /opt/bitnami/Test2/
  <Directory "/opt/bitnami/Test2">
    Options -Indexes +FollowSymLinks -MultiViews
    AllowOverride None
    Require all granted
    # BEGIN WordPress fix for plugins and themes
    # Certain WordPress plugins and themes do not properly link to PHP files because of symbolic links
    # https://github.com/bitnami/bitnami-docker-wordpress-nginx/issues/43
    RewriteEngine On
    RewriteRule ^bitnami/wordpress(/.*) $1 [L]
    # END WordPress fix for plugins and themes
    # BEGIN WordPress
    # https://wordpress.org/support/article/htaccess/#basic-wp
    RewriteEngine On
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress
  </Directory>
  Include "/opt/bitnami/apache/conf/vhosts/htaccess/Test2-htaccess.conf"

  ...
</VirtualHost>

Note: You only need to include the alias, directory and include lines, the previous lines are already in those files

Remember to restart Apache later.

1 Like

I did as you suggested but in the end it my Apache was not able to restart and am facing the same issue currently.

image

Please elaborate all steps.

Show details of wordpress-vhost.conf & wordpress-https-vhost.conf files for running Test2 and Test3 (2 applications/sites ) which we would like to run as folders.

Thanks a lot Jota it solved issue and also I learned how to set virtual hosts in vhost.conf …

Thanks a lot.

1 Like

Now my domain name is unable to map with IP how can I do it ?

for example i want to map xyz.abc.in with my Test 2 site ( /opt/bitnami/Test2), How to do it ?

Hi @kirbyfran56,

You need to create new test2-vhost.conf and test2-https-vhost.conf files under the vhosts folder and set the ServerAlias parameter to the domain you want to use.

https://docs.bitnami.com/aws/apps/wordpress/administration/create-custom-application-php/

1 Like

Greetings

Thanks for your response, I don’t want my IP to be visible so I want Domain to be visible but when I open page source it shows IP ahead of WP-content.

Regards
Fran

That’s due to how the app is configured.

https://docs.bitnami.com/aws/apps/wordpress/administration/configure-domain/

1 Like

Thanks for response.
Please can you tell why is this issue keeps on occuring when I refresh my site.(attached is snapshot of error we are facing).

Regards
Fran

but when I again refresh it, it runs properly.