I need some help with Cannot find any running daemon to contact

Keywords: WordPress - Google Cloud Platform - Technical issue - Services (Apache, MariaDB, MySQL…)

bnsupport ID: 81fccc69-0347-1847-9f7a-5fd819feecb1

bndiagnostic output:

? Apache: Found possible issues
? Connectivity: Found possible issues
? Mariadb: Found possible issues
? Resources: Found possible issues
https://docs.bitnami.com/general/apps/wordpress/troubleshooting/debug-errors-apache/
https://docs.bitnami.com/bch/apps/moodle/troubleshooting/deny-connections-bots-apache/
https://docs.bitnami.com/general/faq/administration/use-firewall/
https://docs.bitnami.com/aws/apps/wordpress/troubleshooting/debug-errors-mariadb/
https://docs.bitnami.com/installer/faq/linux-faq/administration/increase-memory-linux/

bndiagnostic failure reason: I do not know how to perform the changes explained in the documentation

Description:
Hi

I got some db issue after instance reset on wordpress multisite ( main site disappeared) … and trying to reset mariadb, I broke everything…
sudo /opt/bitnami/ctlscript.sh status

Cannot find any running daemon to contact. If it is running, make sure you are pointing to the right pid file (/var/run/gonit.pid)

I tried lots of tutorials and still nothing works.
Please help

Hello @lukasz.apex,

Thanks for using our WordPress stack! Could you please try following the instructions of the following thread:

Apart from that, it seems System Apache is running:

root 2494 0.0 0.2 8428 4148 ? Ss 16:14 0:00 /usr/sbin/apache2 -k start www-data 2496 0.0 0.3 754320 5940 ? Sl 16:14 0:00 /usr/sbin/apache2 -k start

If Bitnami Apache isn’t starting this is the most likely cause. Please run the following command to stop it:

sudo systemctl disable apache2 && sudo systemctl stop apache2

Regards,
Francisco de Paz

Hi Francisco,

Thanks for your help, I know already what could be a problem, but still don’t know how to fix it.
I think I accidentally switched from mysql to mariadb database and this is causing a problem.
Do you know how can I switch back to mysql?

apache not running
mariadb not running
php-fpm already running

Hello @lukasz.apex,

Could you explain what did you do to switch the database? The instance comes with MariaDB installed, did you mean you installed a MySQL besides that? I’m seeing a /opt/bitnami/mysql folder, did you change your WP configuration to use the MySQL database instead of the MariaDB one?

Regards,
Francisco de Paz

Hi

I just have there a wordpress multisite with mysql. I got some issue with this and when I was trying to fix it I pasted some commend do console from some other topic something like this:

sudo /opt/bitnami/mariadb/bin/mysqld_safe --defaults-file=/opt/bitnami/mariadb/conf/my.cnf --pid-file=/opt/bitnami/mariadb/tmp/mysqld.pid --init-file=/home/bitnami/mysql-init 2> /dev/null &

I know, I’m an idiot to use commends I don’t understand… but after that all stopped work

Hello @lukasz.apex,

Don’t worry, let’s try to solve this. The issue should be coming from having different Apache and database from the one shipped in the stack running. To fix this, you need to stop these running processes. First stop Bitnami processes and check the current ones by running:

sudo /opt/bitnami/ctlscript.sh stop
ps aux | grep 'apache\|mysql\|nginx\|/opt/bitnami\|php-fpm'

That will output a list that follows the structure:

USER         PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
daemon    8766 26.3  0.7 429324 255240 ?       S    18:09  39:39 php-fpm: pool www

Search the list for any process and stop any that runs /opt/bitnami/apache2/bin/httpd.bin or /opt/bitnami/mysql/bin/mysqld.bin using the process PID to run the command:

kill -9 PID

After that, try restarting the instance and then star the Bitnami processes:

sudo /opt/bitnami/ctlscript.sh restart

Regards,
Francisco de Paz