I need help urgent mariadb not running nginx not running php-fpm not running

Keywords: WordPress + NGINX + SSL - AWS - Technical issue - Other
bnsupport ID: 88d7750d-5879-60cc-49b1-02e4486850d8
Description:
urgent help

I have stopped the bitnami + nginx services to install a security certificate, I try to get the service up and it does not work.

when executing the command bitnami @ ip-172-31-23-49: / $ sudo /opt/bitnami/ctlscript.sh status
mariadb not running
nginx not running
php-fpm not running
and nothing works, I have already been 1 day of my app off the air. I need help, urgently.

the code that the bitnami support tool threw is 88d7750d-5879-60cc-49b1-02e4486850d8

Hi @edwin.ruiz,

Have you tried running the start command?

sudo /opt/bitnami/ctlscript.sh start

If that doesn’t work, what’s the output of the following commands?

sudo gonit status all
sudo gonit restart all
sleep 5
sudo /opt/bitnami/ctlscript.sh status

Our support tool detected that your machine doesn’t have enough free RAM memory available. Please increase the RAM memory of your instance.

Happy to help!


Was my answer helpful? Click on :heart:

hello

bitnami@ip-172-31-23-49:/$ sudo /opt/bitnami/ctlscript.sh start
Starting services…
Job for bitnami.service failed because the control process exited with error code.
See “systemctl status bitnami.service” and “journalctl -xe” for details.

bitnami@ip-172-31-23-49:/$ sudo gonit status all

Uptime 278h31m43s
Last Check 2021-06-02 12:13:15.313400706 +0000 UTC m=+1002601.733058434
Next Check 2021-06-02 12:15:15.313400706 +0000 UTC m=+1002721.733058434
Pid 1785
Pid File /var/run/gonit.pid
Control File /etc/gonit/gonitrc
Socket File /var/run/gonit.sock

bitnami@ip-172-31-23-49:/$ sudo gonit restart all
bitnami@ip-172-31-23-49:/$ sudo /opt/bitnami/ctlscript.sh status
mariadb not running
nginx not running
php-fpm already running

Hi @edwin.ruiz,

Let’s get the status of the bitnami service

sudo service bitnami status

Did you try to increase the machine’s memory as I mentioned in my previous message?

bitnami@ip-172-31-23-49:~$ sudo service bitnami status
● bitnami.service - LSB: bitnami init script
Loaded: loaded (/etc/init.d/bitnami; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2021-06-02 13:29:20 UTC; 1min 50
Process: 898 ExecStart=/etc/init.d/bitnami start (code=exited, status=1/FAILUR
Tasks: 21 (limit: 2373)
Memory: 141.5M
CGroup: /system.slice/bitnami.service
├─670 php-fpm: master process (/opt/bitnami/php/etc/php-fpm.conf)
├─674 php-fpm: pool www
├─675 php-fpm: pool www
├─676 php-fpm: pool www
├─677 php-fpm: pool www
├─678 php-fpm: pool www
├─679 php-fpm: pool www
├─680 php-fpm: pool www
├─681 php-fpm: pool www
├─682 php-fpm: pool www
├─683 php-fpm: pool www
├─684 php-fpm: pool www
├─685 php-fpm: pool www
├─686 php-fpm: pool www
├─687 php-fpm: pool www
├─688 php-fpm: pool www

and yes increase the machine’s memory to 2g

Hi @edwin.ruiz,

can you run the Bitnami Support tool again to see if there are new information in the logs?

Please note that you need to paste the code ID that is shown at the end.

hello

1afd9f4d-a244-fe77-bdb0-49efd1597be8

Let’s try to reset Gonit as it doesn’t get the status of the services properly. Can you run these commands?

sudo pkill -f gonit
sudo rm /var/run/gonit.sock
sudo /opt/bitnami/ctlscript.sh start
sudo /opt/bitnami/ctlscript.sh status

More info here: Ctlscript status shows as daemon not running

If the services are not started, let’s try to start Nginx manually:

sudo /opt/bitnami/scripts/nginx/stop.sh
sudo /opt/bitnami/scripts/nginx/start.sh
ps aux | grep nginx
tail -n 20 /opt/bitnami/nginx/logs/error.log

Can you access your website now? If that works, you will need to do the same with php and mariadb.

Thanks

I can now enter my site without problems, now I need to use the ssl certificate of my main domain created by aws, how do I do it?

hello good mornig ???

Hi @edwin.ruiz,

Perfect!

I understand you want to generate a Let’s Encrypt certificate, right?

https://docs.bitnami.com/aws/how-to/generate-install-lets-encrypt-ssl/#alternative-approach

I have my main domain already with an ssl certificate provided by amazon web services and I need to use it with this instance, how can I do it?

[image]

Hi @edwin.ruiz,

You can either point the domain to your instance’s IP and configure the SSL certificates in the instance following this guide

https://docs.bitnami.com/aws/apps/wordpress-pro/administration/enable-https-ssl-nginx/

or use a load balancer with your domain and certificate

https://docs.bitnami.com/aws/how-to/configure-elb-ssl-aws/

Happy to help!


Was my answer helpful? Click on :heart:

dear my ssl security certificate is configured in certicarte manager aws and is in route 53 of amazon web service, in this case how does it work?

Hi @edwin.ruiz,

In order to use the AWS Cert Manager service, you need to use another AWS service like Elastic Load Balancing. The second guide I posted above explains how to deploy a Load Balancer in AWS and configure it with an AWS Cert Manager certificate, did you take a look at it? Please note that if you want to use the certificate in a different way, you will need to ask the AWS team to know if that option is possible.

I understand, from bitnami or wordpress should I do something additional or are they just the indications of the aws support team?

Hi @edwin.ruiz,

If you use the Load Balancer, you will need to make changes in the configuration. You can find all the information in the url I posted above.